NodeJS system clock seems off on Stackato

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: kumar, Assigned: cturra)

Tracking

Details

STR: run this code in a node.js app on Stackato:

    var ts = Date.now();
    console.log(ts);
    var newDate = new Date();
    newDate.setTime(ts);
    console.log(newDate.toUTCString());

Here's what I got on Stackato:

2013-04-17T09:30:58+0200 app.0: 1366183858522
2013-04-17T09:30:58+0200 app.0: Wed, 17 Apr 2013 07:30:58 GMT

Here's what I get on my local laptop at the same time:

1366363880594
Fri, 19 Apr 2013 09:31:20 GMT

Is the clock wrong on Stackato?
(Assignee)

Comment 1

6 years ago
it looks like one of the Droplet Execution Agent (DEA) was not picking up updates from our ntp servers. i stopped the ntp service, manually updated and started again.

i suspect the root cause of this was having to roll back to a VM snapshot earlier in the week after a failed maintenance.

root@stackato-dea1:~# service ntp stop
 * Stopping NTP server ntpd            [ OK ]

root@stackato-dea1:~# ntpdate 10.22.75.40
19 Apr 09:40:46 ntpdate[25950]: step time server 10.22.75.40 offset 180029.044115 sec

root@stackato-dea1:~# date
Fri Apr 19 09:40:51 PDT 2013

root@stackato-dea1:~# service ntp start
 * Starting NTP server ntpd            [ OK ]
Assignee: server-ops-webops → cturra
Status: NEW → RESOLVED
Last Resolved: 6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Fantastic, thanks for the quick fix.
Status: RESOLVED → VERIFIED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
No longer blocks: 1023458
You need to log in before you can comment on or make changes to this bug.