Last Comment Bug 863672 - Port configure.in changes to comm-aurora
: Port configure.in changes to comm-aurora
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Build Config (show other bugs)
: 22
: All All
: -- normal (vote)
: Thunderbird 22.0
Assigned To: Frank Wein [:mcsmurf]
:
Mentors:
Depends on:
Blocks: 862701
  Show dependency treegraph
 
Reported: 2013-04-19 04:04 PDT by Frank Wein [:mcsmurf]
Modified: 2013-05-09 03:34 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Patch (2.92 KB, patch)
2013-04-19 05:25 PDT, Frank Wein [:mcsmurf]
no flags Details | Diff | Review
Patch (2.92 KB, patch)
2013-04-19 05:26 PDT, Frank Wein [:mcsmurf]
Pidgeot18: review+
standard8: approval‑comm‑aurora+
Details | Diff | Review

Description Frank Wein [:mcsmurf] 2013-04-19 04:04:57 PDT
We need to port a few changes from mozilla-aurora configure to configure.in one last time (basically, Bug 846540 fixed most cases where configure.in changes had to be ported).
Basically SeaMonkey needs the MOZ_GAMEPAD and the MOZ_WEBSPEECH changes from Bug Bug 604039 and 650295 to fix quite a few tests (maybe this bug should go to the SeaMonkey product).
See http://hg.mozilla.org/mozilla-central/annotate/f8d27fe5d7c0//configure.in#l5921 for MOZ_GAMEPAD and http://hg.mozilla.org/mozilla-central/annotate/f8d27fe5d7c0//configure.in#l5354 for MOZ_WEBSPEECH.
Comment 1 Frank Wein [:mcsmurf] 2013-04-19 05:25:43 PDT
Created attachment 739548 [details] [diff] [review]
Patch

This seems to fix the issue (it's still building, I'm not really a configure.in expert :)
Comment 2 Frank Wein [:mcsmurf] 2013-04-19 05:26:54 PDT
Created attachment 739549 [details] [diff] [review]
Patch

Forgot to hg qrefresh
Comment 3 Frank Wein [:mcsmurf] 2013-04-19 09:16:50 PDT
Thunderbird comm-aurora Try build worked fine (build only, no tests)
Comment 4 Frank Wein [:mcsmurf] 2013-04-19 09:26:41 PDT
Comment on attachment 739549 [details] [diff] [review]
Patch

This patch copies over the required changes from mozilla/configure.in. I only changed this line
AC_CHECK_HEADERS([linux/joystick.h])
from
MOZ_CHECK_HEADER([linux/joystick.h])
(comm-* does not know the MOZ_CHECK_HEADERS macro)

Note: This is a comm-aurora patch, comm-central does not need this patch (anymore)
Comment 5 Frank Wein [:mcsmurf] 2013-04-19 09:27:30 PDT
I meant:
"(comm-* does not know the MOZ_CHECK_HEADER macro)" (without the S)
Comment 6 Frank Wein [:mcsmurf] 2013-04-30 16:26:22 PDT
Comment on attachment 739549 [details] [diff] [review]
Patch

This patch is needed for comm-aurora only, comm-central does not need this (anymore).
Comment 7 Joshua Cranmer [:jcranmer] 2013-05-07 05:48:33 PDT
Comment on attachment 739549 [details] [diff] [review]
Patch

Review of attachment 739549 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +4404,5 @@
> +    MOZ_WEBSPEECH=,
> +    MOZ_WEBSPEECH=1)
> +
> +if test -n "$MOZ_WEBSPEECH"; then
> +    AC_DEFINE(MOZ_WEBSPEECH)

It looks like in mozilla-aurora, MOZ_WEBSPEECH also implies MOZ_MEDIA.
Comment 8 Frank Wein [:mcsmurf] 2013-05-07 05:59:58 PDT
Comment on attachment 739549 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: SeaMonkey browser tests fail, maybe also has unknown user impact (not known if there are bugs that are caused by this)
Testing completed (on c-c, etc.): Patch cannot be tested on comm-central as it applies to comm-aurora only
Risk to taking this patch (and alternatives if risky): Few risk I would say, the variables enabled/disabled by this patch get only used in the comm-central build system. Whether or not the core code in mozilla/ (which those configure vars apply to) gets built is "decided" by mozilla/configure.in and not by the comm-central configure.in. The configure changes here are only needed to fix the installer package manifest (because the manifest uses ifdefs).
Comment 9 Frank Wein [:mcsmurf] 2013-05-07 06:25:03 PDT
Pushed: https://hg.mozilla.org/releases/comm-aurora/rev/5a3559594fce

Note You need to log in before you can comment on or make changes to this bug.