Closed Bug 863707 Opened 9 years ago Closed 8 years ago

Change about:reader to fix obscure bug where article in ReaderMode has incorrect ReaderBanner Add/Remove Icon Status

Categories

(Firefox for Android Graveyard :: Reader View, defect)

23 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(fennec+)

RESOLVED DUPLICATE of bug 923086
Tracking Status
fennec + ---

People

(Reporter: capella, Assigned: capella)

Details

Currently when initiating readerMode we pass the pages' "In readingList?" status as a url parm &readingList=0 or 1 ...

While in reading mode this status can change by activity in that page, other open tabs, readinglist modifications, etc which we track through observers while in the page.

However, navigation forward/backward from the page or refreshes while in it, can get this status out of synch.

This can be fixed by checking the readingList status on entry, rather than relying on it being passed in from callers.
Summary: Change about:reader to check if the article is in the reading list cache on startup → Change about:reader to fix obscure bug where article in ReaderMode has incorrect ReaderBanner Add/Remove Icon Status
STR |can get this status out of synch| from previous comment, assuming bug 802093 is now in Nightly

Step #1
    Start FF with no items in ReadingList
    Navigate to arstechnica.com
        Select/Tap first article in list to Navigate to Page-for-Testing
        Toggle ReaderMode icon to open page in ReaderMode
        Observe ReaderBanner indicates:
            1) Page not in ReadingList yet (Add/Delete Icon is Page-with-Plus-sign)
            2) No Pages are in ReadingList yet (Icon is grayed/Disabled)

Step #2
    Click Add Icon to add Page-for-Testing to ReadingList
        Observe ReaderBanner indicates:
            1) This Page is now in ReadingList (Add/Delete Icon is Trashcan)
            2) ReadingList has one or more entries (Icon is black/Enabled)

Step #3
    Toggle ReaderMode icon once to exit Page-for-Testing from ReaderMode
    Toggle ReaderMode icon once to re-enter Page-for-Testing into ReaderMode
    Observe ReaderBanner status still same as in Step #2

Step #4
    Click any blue link in Page-for-Testing to navigate out of ReaderMode
       to Unrelated-Page
    Tap/Open Awesomebar
    Tap/Select Bookmarks Tab
    Tap ReadingList folder entry to see list
    Long tap only entry in ReadingList (Page-for-Testing entry added by us in Step #2)
    Select Remove from ContextMenu
    Observe empty ReadingList

    click Back to main Bookmarks List
    click Back to Unrelated-Page
    click Back to Page-for-Testing

    Observe Readerbanner status indicates:
        1) Page is still in ReadingList (Add/Delete Icon is Trashcan)
           --- This is wrong ---
        2) No Pages are in ReadingList (Icon is grayed/Disabled)
           --- This is correct ---
tracking-fennec: --- → ?
Assignee: nobody → markcapella
tracking-fennec: ? → +
This was later duped by bug 923086 where I now have patches waiting approval.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 923086
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.