dynamic html menus don't work

VERIFIED DUPLICATE of bug 83332

Status

()

Core
DOM: Core & HTML
VERIFIED DUPLICATE of bug 83332
17 years ago
10 years ago

People

(Reporter: jkng, Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win98; U)
BuildID:    2001061720

The cross browser dynamic html menus on the above page does not work. When you 
mouseover the top navigation, the menu shows up put clicking on a menu item does 
not take you to any new page. 


Reproducible: Always
Steps to Reproduce:
Read above.

Actual Results:  Selecting menu item does not do anything.

Expected Results:  It should take you to another page.

BTW, The dynamic menus were created by macromedia fireworks which based the code 
on Netscape's Gary Smith's Cross-Browser Dynamic HTML Menus script. Since this 
script is produced by a major web publishing software company, I would assume 
alot of people are/will be using this script on their sites. This bug would 
render sites using this script useless.

Comment 1

17 years ago
Can anyone spot the onclick event being set? There's a mass of javascript that
_could_ be attaching it, but no onclick() in the html source...
OS: Windows 98 → All
Hardware: PC → All

Comment 2

17 years ago
Here's the javascript + html that causes the problems:
(There's an exception written to the Javascript console)


<html>
<head>
<script>
function init()
{
  document.getElementById('test').addEventListener("click", click, false);
}
function click(e,l)
{
  eval("location='/index.html'");
}
</script>
</head>
<body onLoad=init();>
 <div id="test">
  Clicking here should take you to the bugzilla home page
 </div>
</body>
</html>

Comment 3

17 years ago
Created attachment 38916 [details]
testcase

Comment 4

17 years ago
My testcase causes the following to be written to the javascript console:

Error: [Exception... "Failure"  nsresult: "0x80004005 (NS_ERROR_FAILURE)" 
location: "JS frame ::
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=38916 :: click :: line
10"  data: no]
Source File: http://bugzilla.mozilla.org/showattachment.cgi?attach_id=38916
Line: 10

Comment 5

17 years ago
the  
   eval("location='<url>'");
works when the <url> is a full url, but not if it is a partial url.

Comment 6

17 years ago
DUP bug 49312 ?
No, this looks like a recent problem... see also bug 86307.  I bet it's the same
problem.
(Assignee)

Comment 8

17 years ago
This is a dup of bug 83332, which was fixed yesterday.

*** This bug has been marked as a duplicate of 83332 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
Created attachment 43791 [details]
testcase

Comment 10

17 years ago
the testcase created below does not show errors in console ....i gave the
absolute path..but using the testcase provided by Conor Lennon (which uses
relative url) still the problem exists thought the page is loaded in both cases...
looks like DUP of 86307....
marking as VERIFIED DUP of 86307
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.