Event - (2013-04-23 11:00 UTC-4) - Ten Forward - Effective Race Detection for Event-Driven Programs

RESOLVED FIXED

Status

Air Mozilla
Events
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Azita, Unassigned)

Tracking

Details

(Whiteboard: Programmed)

(Reporter)

Description

5 years ago
Topic: Effective Race Detection for Event-Driven Programs
Presenter: Manu Sridharan
Date: 2013-04-23
Time: 11:00 UTC-4
Duration: 1 Hour
Privacy: The Public
Large Screen Location: MTV, 
Description: 
Abstract: Like shared-memory multi-threaded programs, event-driven programs are susceptible to data races that are hard to reproduce and debug.  However, the pervasive use of ad hoc synchronization in such programs can lead a dynamic race detector to report too many false positives.  Race detection for such programs also faces a scalability challenge, as a large number of short-running event handlers can overwhelm standard vector-clock-based techniques.

We present a novel race detector EventRacer that addresses both of these challenges.  We introduce race coverage, a systematic method for exposing ad hoc synchronization and other key races to the user, significantly reducing false positives. We also present an efficient connectivity algorithm that uses chain covers to dramatically decrease the overhead of vector clocks.  We show that for client-side web applications, our techniques lead to large performance and precision improvements over state-of-the-art techniques.
Special Requirements:
Whiteboard: Programmed

Updated

5 years ago
Duplicate of this bug: 847572

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.