Support Skype as a chat protocol in Thunderbird

RESOLVED DUPLICATE of bug 953999

Status

--
enhancement
RESOLVED DUPLICATE of bug 953999
6 years ago
5 years ago

People

(Reporter: myoo60, Unassigned)

Tracking

17 Branch

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Opened up thunderbird, chat tab.
Show accounts, then + New Account.


Actual results:

I see
facebook
google talk
irc
twitter
xmpp


Expected results:

I want to see skype also.
This probably does not qualify as a bug - more like a new feature request.
But I do not know where to go for this request.
I want to see thunderbird chat also support skype.

Comment 1

6 years ago
Please see https://getsatisfaction.com/mozilla_messaging/topics/how_do_you_use_the_new_tbird_chat_capability_with_skype_chat
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
There's a Skype Protocol Plug-in summer of code project proposal...
https://wiki.mozilla.org/Community:SummerOfCode13#Thunderbird
Status: RESOLVED → UNCONFIRMED
Component: Untriaged → Instant Messaging
Resolution: INVALID → ---

Updated

6 years ago
Summary: Can thunderbird chat support skype? → Instantbird to support skype chat
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Instantbird to support skype chat → Support Skype as a chat protocol in Thunderbird
Sorry, I should have put a comment in there too.

(In reply to Andre Klapper from comment #1)
> Please see
> https://getsatisfaction.com/mozilla_messaging/topics/
> how_do_you_use_the_new_tbird_chat_capability_with_skype_chat
Almost all the information in this thread is wrong. Skype uses a closed protocol, but there are ways to interface to it with an SDK called SkypeKit.

Most likely we'd do this as an add-on, by the way. At least initially.

(In reply to Magnus Melin from comment #2)
> There's a Skype Protocol Plug-in summer of code project proposal...
> https://wiki.mozilla.org/Community:SummerOfCode13#Thunderbird
We've had a few inquires about this and will hopefully get some good applications. I think you mean https://wiki.mozilla.org/Community:SummerOfCode13#Instantbird, though.

We have an open Instantbird bug with a bit of information: https://bugzilla.instantbird.org/show_bug.cgi?id=563

Updated

6 years ago
Duping to the Chat core bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 953999
You need to log in before you can comment on or make changes to this bug.