Tabular report elements do not link to correct query results

VERIFIED DUPLICATE of bug 653597

Status

()

Bugzilla
Reporting/Charting
VERIFIED DUPLICATE of bug 653597
5 years ago
3 years ago

People

(Reporter: Devon Hubbard, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20130418 Firefox/23.0
Build ID: 20130418031048

Steps to reproduce:

Using any Bugzilla 4.2.5 site, or bugzilla.mozilla.org ...

> https://bugzilla.mozilla.org/query.cgi

1) Click on 'Reports' link
2) Set 'Vertical Axis' to 'Assignee Real Name'
3) Set 'Horizontal Axis' to 'Target Milestone'
4) If bz instance uses Classifications, select a valid classification.  For example in 'bugzilla.mozilla.org', select 'Server Software'.
5) Select a valid 'Product'.
6) For status, select 'ASSIGNED' and 'REOPENED'.
7) Press 'Generate Report'
8) In the table of the resulting report, click on any specific table cell containing a bug number URL that is *not* in the 'Total' column or 'Total' row (at the bottom).


Example bugzilla.mozilla.org reports query of:
Classification: Server Software
Product: Bugzilla
Status: ASSIGNED, REOPENED

> http://tinyurl.com/cvaflrr


Actual results:

Actual Result:
The bug query that is executed produces a list of all bugs in the tabular report.  This is the query would expect to get *if* you clicked on the bottom/right 'Total' of the tabular report.


Expected results:

Expected Result:
Clicking on a specific bug number next to a assignee and target milestone should result in a bug query for just that specific assignee.
(Reporter)

Comment 1

5 years ago
regression note:
Links in tabular report cells worked correctly in Bugzilla 3.2.x and 3.6.x.
The table linkes are not correct in a 4.2.5 installation. I don't have a previous 4.2.4 or earlier instance to test if this bug has existed in 4.2.x in general.
(Reporter)

Comment 2

5 years ago
The breaking factor for this is using 'Assignee Real Name' as a table axis.

If you change your table to instead use 'Assigned', the table's cell links will contain query links that do produce bug listings for that specific 'Assigned' person.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 653597
(Reporter)

Comment 4

3 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.