Payments flow stuck at "waiting for payments to complete"

RESOLVED FIXED in 2013-04-25

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Assigned: kumar)

Tracking

2013-04-25
Points:
---

Details

(Whiteboard: p=1)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 740047 [details]
logs

steps to reproduce:
1. Tester is in Spain on a Movistar 3G Data network
2. Launch marketplace-dev
3. Start the payment flow for a paid app
4. Log in using Persona
5. Enter PIN and click Continue


expected behavior:
Bango screen-Confirm your Purchase loads

observed behavior:
Screen with user message -"Waiting for payments to complete..." loads and is stuck at this screen

Is this because Bango test server is not set up for Spain?
The scree
(Reporter)

Updated

5 years ago
Assignee: keir → kumar.mcmillan
webpay dev is unable to connect to the marketplace API because of an oauth failure. Andy, do I need to regenerate the oauth token for this user? I was getting the same problem locally but regenerating the oauth token didn't fix it.


Apr 22 03:41:37 celery1.dev.addons.phx1.mozilla.com: [] z.celery:ERROR Celery TASK exception: HttpClientError: Client Error 401: https://marketplace-dev.allizom.org/api/webpay/product/icon/#012Content: #012 :/data/www/marketplace-dev.allizom.org-webpay/venv/src/nuggets/celeryutils.py:46#012Traceback (most recent call last):#012  File "/data/www/marketplace-dev.allizom.org-webpay/venv/src/nuggets/celeryutils.py", line 35, in wrapped#012    return fun(*args, **kw)#012  File "/data/www/marketplace-dev.allizom.org-webpay/venv/lib/python2.6/site-packages/multidb/pinning.py", line 46, in decorator#012    return func(*args, **kw)#012  File "/data/www/marketplace-dev.allizom.org-webpay/venv/lib/python2.6/site-packages/multidb/pinning.py", line 46, in decorator#012    return func(*args, **kw)#012  File "/data/www/marketplace-dev.allizom.org-webpay/venv/lib/python2.6/site-packages/django/db/transaction.py", line 224, in inner#012    return func(*args, **kwargs)#012  File "/data/www/marketplace-dev.allizom.org-webpay/webpay/webpay/pay/tasks.py", line 96, in start_pay#012    icon_url = get_icon_url(pay['request'])#012  File "/data/www/marketplace-dev.allizom.org-webpay/webpay/webpay/pay/tasks.py", line 220, in get_icon_url#012    res = mkt_client.slumber.api.webpay.product.icon.get_object(**data)#012  File "/data/www/marketplace-dev.allizom.org-webpay/venv/lib/python2.6/site-packages/curling/lib.py", line 140, in get_object#012    res = self.get(**kw)#012  File "/data/www/marketplace-dev.allizom.org-webpay/venv/lib/python2.6/site-packages/curling/lib.py", line 127, in get#012    params=kwargs)#012  File "/data/www/marketplace-dev.allizom.org-webpay/venv/lib/python2.6/site-packages/curling/lib.py", line 200, in _request#012    content=self._try_to_serialize_error(resp))#012HttpClientError: Client Error 401: https://marketplace-dev.allizom.org/api/webpay/product/icon/#012Content:
This is fixed for now because I disabled the product icon API (see bug 864451)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: p=1
Target Milestone: --- → 2013-04-25
You need to log in before you can comment on or make changes to this bug.