Closed Bug 864141 Opened 7 years ago Closed 7 years ago

URL auto-complete will redirect to unexpected urls

Categories

(Firefox :: Address Bar, defect)

20 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 769994

People

(Reporter: samth, Unassigned)

Details

As background to the bug, https://www.boston.com has an invalid certificate, and therefore won't load.  However, 'https://boston.com' works (somewhat), and both non-https versions work properly.

When I type in 'boston.com' into the URL bar, the following things happen:

- The first entry in the dropdown is 'https://www.boston.com' (the site worked in the past).
- The location bar auto-completes to 'boston.com/' (note trailing '/')

Then, if I hit Enter, it loads 'https://www.boston.com', which fails.  There is no indication in the location bar that this page will be loaded. In fact, there are two differences from the URL that auto-complete shows: the 'https' and the 'www'. 

If I type '/' and then hit Enter, or delete the autocompleted '/', it correctly loads 'http://boston.com'.
Version: 23 Branch → 20 Branch
This happens both with Nightly (23) and Release (20).
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769994
You need to log in before you can comment on or make changes to this bug.