Error at browser startup if "browser.panorama.experienced_first_run" preference set to true (breaks Web Developer menu)

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: morac, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression

Details

(Reporter)

Description

6 years ago
The following problem occurs in Firefox 21.0 and up (including latest nightlies).

For a while now I've noticed the Web Developer menu is empty in the first browser window and the following error in the error console when Firefox starts up:

Error: NS_ERROR_ILLEGAL_VALUE: 'Illegal value' when calling method: [nsISessionStore::getWindowValue]
Source file: chrome://browser/content/browser.js
Line: 6018

When I created a new profile, the problem went away, so I figured it was an addon doing something weird, but since I it occurred in the old profile with all add-on disabled I thought that was odd.

I finally tracked this down to having the "browser.panorama.experienced_first_run" preference set to true.  Once I removed the preference both problems went away.

The preference gets set once a user adds a tab group and moves tabs around in them, so the problem will only occur for people who have used tab groups.

The problem appears to be that Firefox attempts to read data from the SessionStore API before it's initialized.
(Reporter)

Comment 1

6 years ago
The line causing the error is actually:

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-tabview.js#73

This causes everything after line 1165 in browser.js's _delayedStartup function to not run which prevents the "browser-delayed-startup-finished" notification from firing in certain instances.

See http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#1165
(Reporter)

Updated

6 years ago
Severity: normal → major

Updated

6 years ago
Component: Tabbed Browser → Panorama
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.