Closed Bug 864180 Opened 7 years ago Closed 7 years ago

move audio software decoder from mediaserver process to app's process

Categories

(Core :: Audio/Video, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla23
blocking-b2g leo+
Tracking Status
firefox21 --- wontfix
firefox22 --- wontfix
firefox23 --- fixed
b2g18 + fixed
b2g18-v1.0.0 --- unaffected
b2g18-v1.0.1 --- unaffected

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

(Keywords: perf, regression, Whiteboard: [c= p=3])

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #853977 +++

Create this bug from Bug 853977 comment #63.

Bug 803471, all codecs of OMXCodec move to mediaserver process. But this change add IPC overhead. The overhead become significant when a lot of OMXCodecs are loaded.

Only hardware codecs are needed to be loaded in mediaserver process. Software codecs can be loaded in app's process as in Firefox OS v1.0.1
Blocks: 853977
blocking-b2g: leo+ → leo?
Depends on: 864181
Summary: move mp3 software codec from mediasercver process to app's process → move audio software decoder from mediasercver process to app's process
Summary: move audio software decoder from mediasercver process to app's process → move audio software decoder from mediaserver process to app's process
Assignee: nobody → sotaro.ikeda.g
I thought we weren't using software codecs?
(In reply to Chris Double (:doublec) from comment #2)
> I thought we weren't using software codecs?

Oh audio only, I missed that, thanks.
Some apps like game uses a lot of audio codecs. It increases IPC messages a lot. It causes delay of audio codecs data handling and causes timeout at the codecs. By loading audio software codecs in application process, IPC message can be reduced.
Comment on attachment 740122 [details] [diff] [review]
patch - move audio software decoder to app's process

doublec, can you review the patch?
Attachment #740122 - Flags: review?(chris.double)
Can we get some more information on the user win here if we take this change?  We'll track and look at an uplift nomination with that info as well as a risk assessment, but this is not a blocker based on the lack of data on how this will benefit the user/product.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
user win is speed up of start up time codec load. This come to speed up of "app Poppit" start.
doublec, review ping.
Whiteboard: c=performance p=4
Status: NEW → ASSIGNED
Attachment #740122 - Flags: review?(chris.double) → review+
nominated to leo again.
Without the change, an app that loads a lot of mp3 files failed to load some mp3 files during app's start up because of timeout and then failed to start up the app, like 3rd party app Poppit in Bug 853977 comment #14.
And the change reduces Binder IPC messages, it could speed up apps' start up performance that uses a lot of mp3 files.
blocking-b2g: - → leo?
By applying attachment 740122 [details] [diff] [review], 3rd party app Poppit can start up normally on MozBuild Leo . Before the patch, the app failed to start up because of mp3 file load timeout.
blocking-b2g: leo? → leo+
Keywords: regression
Whiteboard: c=performance p=4 → c=audio p=4
Committable patch. Carry "chris.double: review+"
Attachment #740122 - Attachment is obsolete: true
Attachment #745718 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/658705597992
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Flags: in-moztrap-
Keywords: perf
Priority: -- → P1
Whiteboard: c=audio p=4 → [c= p=3]
You need to log in before you can comment on or make changes to this bug.