Shortcuts that use VK_RETURN keycode should display as "Enter" on non-Mac platforms

RESOLVED DUPLICATE of bug 106327

Status

()

Core
XP Toolkit/Widgets: Menus
RESOLVED DUPLICATE of bug 106327
5 years ago
4 years ago

People

(Reporter: crussell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 740130 [details]
Menu showing item with shortcut labeled as "Ctrl+Shift+Return"

The sepsis console has a menu item to toggle the input's multi-line mode, and it's wired up to the <key>.  It uses the VK_RETURN keycode:

(From <http://hg.mozilla.org/users/sevenspade_gmail.com/sepsis/file/e862d2035f22/resources/content/main/console.xul#l129>>)
>     <key id="key_multiLineMode"
>          modifiers="accel,shift"
>          keycode="VK_RETURN"
>          command="cmd_multiLineMode"/>

This shows up as "Ctrl+Shift+Return".  Sensible, but a little foreign if you aren't on a Mac.

STR:
1. Open a menu containing an item whose command can be invoked with a shortcut that uses VK_RETURN.

Expected results:
The acceltext uses "Enter" on non-Mac platforms, and "Return" on Mac.

Actual results:
The acceltext uses "Return" on all platforms.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 106327
You need to log in before you can comment on or make changes to this bug.