Video player plugins not auto-activating

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
6 years ago
3 years ago

People

(Reporter: jfrim, Unassigned)

Tracking

SeaMonkey 2.17 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17.1
Build ID: 20130410205058

Steps to reproduce:

In the "Scripts & Plugins" Advanced Preferences, enabled the "Activate all plugins by default" checkbox.  Then visited any website with inline video (eg. YouTube), and visited http://vk.com/audio/ to play music.


Actual results:

1.  Areas where video player should appear on web sites displays grey box with "lego brick" icon and "Click here to activate plugin" text.

2.  Clicking the PLAY button (right-pointing arrow) on songs on vk.com does nothing.


Expected results:

1.  Video player should auto-activate for web sites with video, when above-mentioned checkbox is enabled.

2.  Music playback should begin on vk.com when clicking the PLAY button.
(Reporter)

Comment 1

6 years ago
Set importance to "Major", since for some web sites (like vk.com ), there is no "Click here to activate plugin" widget, and therefore the site features remain impossible to use with SeaMonkey.
Severity: normal → major

Comment 2

6 years ago
> enabled the "Activate all plugins by default" checkbox.

Try turning this off.
(Reporter)

Comment 3

6 years ago
Same thing.
The "Activate all plugins by default" setting, be it enabling it or disabling it, does not seems to change the web browser operation.

Comment 4

6 years ago
WFM.
Just as you describe. Clicking PLAY (right-pointing arrow), the song plays inline.
Play, pause, jump & volume controls all working as expected.
 
 
Suppose you want a URL like: http://vk.com/music  or (better) http://vk.com/club96436
 
 
What plugins do you have?
Do you have Flash?
Anything blocking Flash (Flashblock or Noscript)?
(Reporter)

Comment 5

6 years ago
Plugins installed and enabled:
Adobe Acrobat 9.5.4.268
Java Deployment Toolkit 6.0.290.11
Shockwave Flash 11.4.402.265

There are a few others that are all disabled (Java Platform SE6 U29 6.0.290.11, Microsoft DRM 9.0.0.4503, Octoshape Streaming Services 20000.9.407.0, Windows Media Player Plug-in Dynamic Link Library 3.0.2.629, Windows Presentation Foundation 3.5.30729.1)


Extensions installed and enabled:
ChatZilla 0.9.90
DOM Inspector 2.0.14
JavaScript Debugger 0.9.89
VKontakte.ru Downloader 0.3.5.1pre


I did not add, remove, enable, disable, or change any of the plugins or extensions settings when this problem started occurring.
I also never changed the "Activate all plugs by default" setting in Preferences when this problem started occurring.
SeaMonkey does auto-upgrade itself, so I can only suspect the new version to which it upgraded has an auto-activation flaw that the old version did not have.

Comment 6

6 years ago
Your Flash is quite dated (& vulnerable).
Update to current (11.7.700.169).
Does the problem persist?

Restart in Safe Mode, does the problem persist?
(Help | Restart with addons disabled)

As a test, create a new, clean Profile.
Does the problem persist?

As a test, if you revert to an earlier version of SeaMonkey, does the problem persist?

Comment 7

6 years ago
Actually, your version of Flash is blocklisted:
 
 
Flash Player Plugin between 11.0 and 11.4.* (click-to-play) has been blocked for your protection.
https://addons.mozilla.org/en-US/seamonkey/blocked/p178

Comment 8

3 years ago
Never confirmed by a second user, No response to Comment 6, Comment 7, so I close this one for now.

@Reporter: Please feel free to reopen this Bug if you still can reproduce the problem with a current SeaMonkey version, current plugin version and a current OS and if you can contribute a step by step instruction due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>  (containing every key press and every mouse click) how to reproduce the problem reliably.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
Summary: plugins not auto-activating → Video player plugins not auto-activating
You need to log in before you can comment on or make changes to this bug.