If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[xpcdom] Cannot set custom JS properties on <select> field objects.

VERIFIED FIXED

Status

()

Core
DOM: Core & HTML
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Jason Johnston, Assigned: jst)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1+)
Gecko/20010618
BuildID:    2001061804

Applies to builds post-0.9 (0.9 worked correctly):

It is not possible to set custom properties of an HTML <select> field object, ie. 
document.formName.selectName.customProperty="string";
An uncaught exception error is thrown in the JS console.

Setting custom properties on other types of fields works correctly.

Testcase will be attached.
(Reporter)

Comment 1

17 years ago
Created attachment 38940 [details]
testcase
Sounds like an xpcdom problem.... Seeing this on Linux with 2001-06-17-21 as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Summary: Cannot set custom JS properties on <select> field objects. → [xpcdom] Cannot set custom JS properties on <select> field objects.

Comment 3

17 years ago
Confirmed on Build 2001061804 win32
javascript console shows:

Error: uncaught exception: [Exception... "Failure"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=38940 :: validate ::
line 7"  data: no]
*** Bug 86672 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

17 years ago
Fixed by my DOM array checkin last night.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

16 years ago
Verified fixed.  Thanks jst!
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.