Options panel doesn't respect ordinal values for tools

RESOLVED DUPLICATE of bug 862398

Status

()

Firefox
Developer Tools: Framework
RESOLVED DUPLICATE of bug 862398
5 years ago
5 years ago

People

(Reporter: rc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Disabling and enabling tools in the Options panel causes a tool to disappear from the toolbox (OK) and when re-enabled, it will appear at the end of tabs irrespective of its specified ordinal value.

see: http://mxr.mozilla.org/mozilla-central/source/browser/devtools/framework/ToolDefinitions.jsm#76

Tools return to their proper ordering after closing and reopening the toolbox.
BWAHAHAHAHAHA ;)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862398
You need to log in before you can comment on or make changes to this bug.