no error message (just spinner) when password for account becomes incorrect

RESOLVED DUPLICATE of bug 863807

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 863807
5 years ago
5 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I changed the password for an account that I had set up in the Firefox OS email client.  When I start the email client (which now no longer has the correct password), I see the "Inbox" view of that account, and it just has "[spinner] loading messages".  I should get some sort of UI telling me the password is wrong and preferably leading me to enter the correct password.

Steps to reproduce:
 1. set up an email account and use it successfully
 2. change the password for that account
 3. start the email app and go to that accounts inbox

Actual results: [spinner] loading messages

Expected results: error, preferably leading me to enter the password
Oops, should have mentioned I'm on a self-built v1-train build built a few hours ago, on an Otoro.
Though I'm still just seeing the spinner after fixing the password, so maybe the email client is just busted today?
Yes, there are TCPSocket regressions currently happening across all branches.  A password prompt is displayed when we are able to talk to the server and it appears to be generating an authentication failure (or we can't further narrow down the server's error message and just assume it's an authentication error).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 863807

Updated

5 years ago
blocking-b2g: leo? → ---
You need to log in before you can comment on or make changes to this bug.