17 years ago
17 years ago


(Reporter: Ivan Brezina, Assigned: karnaze (gone))




Firefox Tracking Flags

(Not tracked)




(1 attachment)



17 years ago
Silly, but mortal. 
This URL was generated on error 404 page using HTTP_REFERER.

Comment 1

17 years ago
works on build 2001061804 win32 (linux only bug?)

reporter: please specify build id
OK.  I just tried this...  and I crash no matter whether I use %2e or "."

#0  0x40d7e7a9 in gCharSetMap ()
   from /home/bzbarsky/mozilla/debug/mozilla/dist/bin/components/
#1  0x40d5d3d7 in nsFontGTKNormal::GetWidth (this=0x8847468, aString=0xbfffa6ee, 
    aLength=1) at nsFontMetricsGTK.cpp:1958
#2  0x40d6d42e in nsRenderingContextGTK::GetWidth (this=0x879e798,
    aLength=7, aWidth=@0xbfffa230, aFontID=0x0) at nsRenderingContextGTK.cpp:1321
#3  0x4178cc84 in nsTextFrame::MeasureText (this=0x87615f0, aPresContext=0x8314208, 
    aReflowState=@0xbfffaa34, aTx=@0xbfffa6cc, aLb=0x870a600, aTs=@0xbfffa814, 
    aTextData=@0xbfffa6a0) at nsTextFrame.cpp:4566

(gdb) frame 1
#1  0x40d5d3d7 in nsFontGTKNormal::GetWidth (this=0x8847468, aString=0xbfffa6ee, 
    aLength=1) at nsFontMetricsGTK.cpp:1958
1958      gint len = mCharSetInfo->Convert(mCharSetInfo,
Current language:  auto; currently c++
(gdb) p mCharSetInfo
Cannot access memory at address 0x170cded2

Over to layout based on stack trace.
Assignee: alecf → karnaze
Severity: normal → critical
Component: URL Bar → Layout
Ever confirmed: true
Keywords: crash
QA Contact: claudius → petersen
Summary: Using %2e instead of dot in hostaname causes a crash → crash on

Comment 4

17 years ago
another problem at same site (not crash) - bug 73816

Comment 5

17 years ago
build id:
debian package cvs.20010618-0. 
id Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.1+) Gecko/20010614

Comment 6

17 years ago
*** Bug 86477 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
I see the almost exact same trace when I crash while reading mail (trace in bug
86477 ).

Comment 8

17 years ago
(W2K, W98SE, EN/DE langpack, NS6.1b1, latest pull_all)

Cannot reproduce! Reporter, can you reproduce?

Comment 9

17 years ago
NO CRASH, however the layout on the linux version is wrong (diff from the
layout on the win32 versions)

(LINUX NS6.1prevrel1, W2K, W98SE, EN/DE langpack, NS6.1b1, latest pull_all)

Cannot reproduce! Reporter, can you still reproduce using the latest versions?

Comment 10

17 years ago
My configuration is debian sid. I am using mozilla cvs snapshots
from deb ./ . In mozilla from 16. 06
this bug appeared this morning. If and only if the dot was replaced by %2e.
Url http://undergroud%2ecz crashed both mozilla and galeon.

Rigth now i have pulled:
galeoncvs cvs.20010622
mozilla cvs.20010622
libnspr4 cvs.20010622
When I enter url http://underground%2ecz mozilla does nothing.
Galeon still crashes.


Comment 11

17 years ago
Still crashes. "does nothing" was caused, becase mozilla sometimes ignores 
ENTER key when editing URL input line. It seems to be debian(sid) related problem.
Anywhere else I could not reproduce this bug. 

But the bug has changed behaviour since previous cvs snapshot:
/usr/lib/mozilla/ line 72:  2480 Segmentation fault  $prog ${1+"$@"}
instead of: 
/usr/lib/mozilla/ line 72:  1578 Illegal instruction     $prog

Comment 12

17 years ago
  seems to me that this bug has to do with a problem we have on linux when using
  META tags like

  <meta http-equiv="Content-Type" content="text/html; charset=utf-8">

  This is an internationalisation problem and is known already.
  If you can, try to see if mozilla is crashing if you remove this tag from
  the page. You'll have to store the page local and modify it. If you cannot
  reproduce the bug anymore then is a dup of 81359 (I suppose at least).
  I'm suspecting this be cause I'm not able to reproduce on my linux machine
  (RH 7.1 EN(US))
  Please try to do this on your machine, seems to me that only you have the
  proper environment to reproduce. thx

Comment 13

17 years ago
I have changed my mozilla source from deb ./ to 
deb ./
Mozila does not crash on http://underground%2ecz any more. sends pages in iso-8859-2 format, but when I enter
underground%2ecz, meta tag in index html contains charset=utf-8. 

The only problem is, that utf-8 version of this page is badly formated.
May be due using different fonts (with wrong metrics) ?

Stored version of this page behaves the same way. Even when I remove meta
tag from page, page gets wery wide.

Comment 14

17 years ago
still crashing, using 2001070121 nightly.
see also bug 88473 - possible dup of this one.
try also - i've got crash with same stack.
Bug 88486 just got fixed, which may well fix this one as well.  Retest please?
worksforme with a 2001-07-05 build, whether I use %2e or .


17 years ago
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 17

17 years ago
marking WORKS FOR ME since no one claims the contrary
You need to log in before you can comment on or make changes to this bug.