all-day event from Google calendar also shows up as a 24hr event the day *before*

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dietrich, Assigned: gaye)

Tracking

unspecified
x86
Mac OS X
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified)

Details

(Whiteboard: c=calendar)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
talked to j-lal on irc, he's got ideas.
(Assignee)

Updated

5 years ago
Assignee: nobody → gaye
(Assignee)

Comment 1

5 years ago
Created attachment 743186 [details]
Pull request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
String or UUID changes made by this patch:
Attachment #743186 - Flags: review?(jlal)
Attachment #743186 - Flags: approval-gaia-v1?
(Assignee)

Comment 2

5 years ago
This regression was introduced in bug #830180. If the uplift is declined, all day events will show on the correct day AND the day before. The patch was manually tested. The risk to taking this patch (since it is simply a revert) is that any UI benefits that were introduced in the original patch to 830180 will be reverted.
(Reporter)

Updated

5 years ago
Blocks: 830180
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 864642

Updated

5 years ago
blocking-b2g: --- → leo?
Comment on attachment 743186 [details]
Pull request

backout r+
Attachment #743186 - Flags: review?(jlal) → review+

Updated

5 years ago
blocking-b2g: leo? → leo+

Updated

5 years ago
Keywords: verifyme
QA Contact: jsmith
Uplifted 3fe18a066d3ae57079abf45d4d37b053b0ef9ea9 to:
v1-train: d55ad9f1a124b7114e70f989213e6d0ec8e94a2a
status-b2g18: --- → fixed

Updated

5 years ago
Whiteboard: c=calendar
Comment on attachment 743186 [details]
Pull request

Already landed per leo+, so no need for approval.
Attachment #743186 - Flags: approval-gaia-v1?

Updated

5 years ago
status-b2g18: fixed → verified
Keywords: verifyme

Updated

5 years ago
Flags: in-moztrap?
https://moztrap.mozilla.org/manage/cases/?filter-id=9277

New test case created to cover this bug.
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.