Random zeroes (0) appearing in html content

VERIFIED FIXED in Firefox 23

Status

()

VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: blissdev, Unassigned)

Tracking

({regression})

23 Branch
mozilla23
x86
All
regression
Points:
---

Firefox Tracking Flags

(firefox22 unaffected, firefox23+ verified)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 740379 [details]
zerosincontent.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:23.0) Gecko/20130422 Firefox/23.0
Build ID: 20130422030937

Steps to reproduce:

Loading a page with DOM insertions via jQuery (1.7.2). Not sure if related, but SVG is rendered on the page as well.


Actual results:

Page renders with seemingly random zeros (the 0 character) between inserted nodes. 


Expected results:

No zeroes should be randomly inserted.
(Reporter)

Comment 1

6 years ago
After more testing, it seems to happen intermittently. This makes it hard to pinpoint what code is causing it.
Hi Jordan, Do you have a url I could take a look at to see if I can duplicate the issue? Or a reduced test case that you could attach?  Thanks!
Flags: needinfo?(blissdev)
(Reporter)

Comment 3

6 years ago
Hi Liz, unfortunately it's not a publicly available application. I will attempt to make a reduced test case that has this issue.
Flags: needinfo?(blissdev)
(Reporter)

Comment 4

6 years ago
Liz, I think I found a public site where this is happening. On Mugasha at the end of a set it will display a popup with next suggested sets. Oftentimes (but not always) this pop-up will contain the zeros that I'm seeing in my own project. 

Example link: http://mugasha.com/international-departures/007#/track/51/Tomcraft-vs.%20The%20Doppler%20Effect/Loneliness%20%28Myon%20&%20Shane%2054%20Summer%20Of%20Dub%20Mix%29%20vs.%20Beauty%20Hides%20In%20The%20Deep%20%28Acapella%29

Comment 5

6 years ago
I see this in Nightly / Linux on phpmyadmin and also at least a local version of phonedash

You might try: http://mrcote.info/phonedash or http://demo.phpmyadmin.net/
OS: Mac OS X → All

Comment 6

6 years ago
Also in Nightly on OS X 10.8.3.

Comment 7

6 years ago
To reproduce: go to http://mrcote.info/phonedash then click the cached checkbox, wait for repaint, repeat until a 0 appears below the legend on the left side of the page.

I first noticed this with yesterday's Nightly. Not reproducible on Aurora.
Keywords: regression, regressionwindow-wanted

Comment 8

6 years ago
I see this on Mozilla's yammer instance with today's nightly on Fedora 17.
I'm seeing this all the time on GroupMe and when upgrading a GitHub instance.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'm seeing this all the time on https://web.tweetdeck.com and games of http://triton.ironhelmet.com. It appears mostly on insertion of content / DOM nodes, afaics.
If you are able to reproduce this please use mozregression to find a regression range:
http://mozilla.github.io/mozregression/

Thank you
Component: Untriaged → DOM
Product: Firefox → Core
tracking-firefox23: --- → ?

Comment 12

6 years ago
using phpmyadmin
Last good nightly: 2013-04-21
First bad nightly: 2013-04-22

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0d50cb959c46&tochange=50d25e083421
(In reply to Bob Clary [:bc:] from comment #12)
> using phpmyadmin
> Last good nightly: 2013-04-21
> First bad nightly: 2013-04-22
> 
> Pushlog:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=0d50cb959c46&tochange=50d25e083421

Thanks Bob. Can you regress this any further with tinderbox builds?

Comment 14

6 years ago
I'm doing manual builds and bisecting atm. I'll let you know later this evening.

Comment 15

6 years ago
STR
1. Open http://mrcote.info/phonedash
2. Toggle "Cached" checkbox
3. Repeat Step2.

Actual Results:
  Rundom numerical number such as 0, 9.346043567475603e-307 appears at end of Legent as follows:
	c8_aa_21_ac_0c_b5_droid-pro 00000


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/123a65dba090
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130420 Firefox/23.0 ID:20130420072406
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/503a5fb6d530
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130420 Firefox/23.0 ID:20130420073304
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=123a65dba090&tochange=503a5fb6d530

Triggered by
503a5fb6d530	Kannan Vijayan — Bug 861596 - Add optimized ArgumentsObject stubs to Ion ICs. r=h4writer


It is better to double-check it about the regression range.

Updated

6 years ago
Duplicate of this bug: 866013

Comment 17

6 years ago
Sorry, typo in comment #15
s/Legent/Legend/

Updated

6 years ago
Blocks: 861596
I've seen this once on the Mozilla Yammer page.  dougt said he's seen it there, too.
Grooveshark's Retro interface reproduces the issue consistently, and is public:

http://retro.grooveshark.com/#!/search?q=test
(In reply to Sean Stangl [:sstangl] from comment #19)
> Grooveshark's Retro interface reproduces the issue consistently, and is
> public:
> 
> http://retro.grooveshark.com/#!/search?q=test

Thanks, adding that to the URL field.
This is utterly bizarre.  I can't fathom how an Ion IC change causes this.  Will take a look.
Happens on TBPL too in the list of trees.

Comment 23

6 years ago
Nice i've seen this one too. Been stuck trying to make a testcase.

Comment 25

6 years ago
Confirmed Alice's bisection via manual builds and hg bisect.
The first bad revision is:
changeset:   129418:503a5fb6d530
user:        Kannan Vijayan <kvijayan@mozilla.com>
date:        Sat Apr 20 10:32:04 2013 -0400
summary:     Bug 861596 - Add optimized ArgumentsObject stubs to Ion ICs. r=h4writer
Keywords: regressionwindow-wanted

Comment 26

6 years ago
The reporter of bug 866075 (about non-zero numbers like in Alice's bug 866013) reported not being able to reproduce it with 2013-04-28.
(In reply to Aleksej [:Aleksej] from comment #26)
> The reporter of bug 866075 (about non-zero numbers like in Alice's bug
> 866013) reported not being able to reproduce it with 2013-04-28.

Makes sense. The revision that introduced this issue has been reverted/backed out on 2013-04-28. That is the revision mentioned in comment 25 .

Updated

6 years ago
Duplicate of this bug: 866075
status-firefox22: --- → unaffected
status-firefox23: --- → affected
tracking-firefox23: ? → +
This bug was fixed in the re-push of patch for bug 861596.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(In reply to Kannan Vijayan [:djvj] from comment #29)
> This bug was fixed in the re-push of patch for bug 861596.

Thanks Kannan.

Anyone on this bug who was seeing this issue, please download or update to today's Nightly and see if this is now resolved for you.

Thank you.

Updated

5 years ago
status-firefox23: affected → fixed
Target Milestone: --- → mozilla23

Comment 31

5 years ago
I can't reproduce the problem in http://hg.mozilla.org/mozilla-central/rev/b842d26dd5f0 that I saw in http://hg.mozilla.org/mozilla-central/rev/503a5fb6d530
Status: RESOLVED → VERIFIED
Thank you Cork.
status-firefox23: fixed → verified
You need to log in before you can comment on or make changes to this bug.