X coordinate of getBBox on text node is negative

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: michael.g.miller, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 740426 [details]
test.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/536.26.17 (KHTML, like Gecko) Version/6.0.2 Safari/536.26.17

Steps to reproduce:

Loaded the file in FF.


Actual results:

-1 was printed.


Expected results:

0 should have been printed, since the text should begin at x=0. This is the behavior of chrome.
Attachment #740426 - Attachment mime type: text/plain → text/html
I get 0 on Linux. Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20130422 Firefox/23.0
Component: Untriaged → SVG
Product: Firefox → Core
I guess for this letter and this font and font-size some pixels of the glyph exist to the left its alignment-point. This can be so sometimes, and that's why you should use getBBox rather than assuming it will be 0.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.