Closed Bug 864495 Opened 7 years ago Closed 7 years ago

Crash on Quora page

Categories

(Core :: JavaScript Engine, defect, critical)

23 Branch
x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 864125

People

(Reporter: fryn, Unassigned)

References

()

Details

(Keywords: crash, regression, reproducible)

Steps to reproduce:
1. Log into Quora.
2. Visit https://www.quora.com/Investing/I-have-5-What-is-the-best-way-to-invest-and-grow-my-money
3. Wait for page to load.
4. Scroll downwards.
5. Scroll upwards.
6. Firefox crashes!
Please provide the crash ID from the about:crashes page.
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Severity: normal → critical
Flags: needinfo?(fyan)
Keywords: crash, stackwanted
I nonsensically had crash reporter disabled for the builds in which I reproduced the crash, but I had a colleague reproduce it, and here is the crash ID for that: 5cb3bc9e-cf2b-4953-828d-2a2e12130422

This seems to be related to bug 821733.

Also: actually, no Quora login is needed to reproduce the crash.
Flags: needinfo?(fyan)
I can't reproduce it in Safe Mode.
How about you, Jared?
I can't reproduce it on a locally built m-c in Safe Mode.
Crash Signature: [@ js::CompartmentChecker::fail(JSCompartment*, JSCompartment*)] Frame Module Signature Source 0 mozjs.dll js::CompartmentChecker::fail js/src/jscntxtinlines.h:153 1 mozjs.dll js::TypeOfOperation js/src/jsinterpinlines.h:921 2 @0x235986
(In reply to Frank Yan (:fryn) from comment #2)
> 5cb3bc9e-cf2b-4953-828d-2a2e12130422
The linkable version is: bp-5cb3bc9e-cf2b-4953-828d-2a2e12130422.

On Windows: bp-fde3dce7-7dd6-4723-b365-ae44b2130422 ie bug 864125.
Assignee: nobody → general
Crash Signature: [@ js::CompartmentChecker::fail(JSCompartment*, JSCompartment*)] Frame Module Signature Source 0 mozjs.dll js::CompartmentChecker::fail js/src/jscntxtinlines.h:153 1 mozjs.dll js::TypeOfOperation js/src/jsinterpinlines.h:921 2 @0x235986
Component: General → JavaScript Engine
Version: Trunk → 23 Branch
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 864125
You need to log in before you can comment on or make changes to this bug.