Closed Bug 864554 Opened 9 years ago Closed 9 years ago

Address bar hides the tops of pages on first load (e.g, Facebook)

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox21 unaffected, firefox22 affected, firefox23 verified)

RESOLVED FIXED
Tracking Status
firefox21 --- unaffected
firefox22 --- affected
firefox23 --- verified

People

(Reporter: alloy45224, Unassigned)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20130421 Firefox/23.0
Build ID: 20130421031002

Steps to reproduce:

Load any page, such as from a bookmark.


Actual results:

The address bar obscures the top portion of the page until it auto-hides.


Expected results:

The "top" of the page should start at the bottom of the address bar. The address bar should be hidden as the user scrolls down. This behavior is particularly annoying on sites such as Facebook where important information is at the top. In order to make the information appear, the user has to wait for the bar to autohide, or scroll up.
OS: Windows 8 → Android
Hardware: x86_64 → ARM
Do you have an example page demonstrating this? There are a couple of known issues, but if you have an example we can check to verify if it's one of the issues already known and filed.
Component: Theme and Visual Design → General
Ah I see Facebook in your screenshot.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Address bar hides the tops of pages on first load. → Address bar hides the tops of pages on first load (e.g, Facebook)
tracking-fennec: --- → ?
Ah, glad someone has reported this. It affects user experience quite a lot of facebook as the top bar is hidden on load (effectively hiding red notification numbers)
This is fixed by the patch attached to bug 858969.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 858969
The regression window for this issue is:

good build: 17.03.2013 
bad build:  18.03.2013 

pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0b052daa913c&tochange=b03bb3ce8cee
The tinderbox inbound builds are missing since the issue is older than one month.
Resolution: DUPLICATE → FIXED
Just to add to this issue (which is likely resolved), I get a similar issue on http://duckduckgo.com/. Once I am able to test the fix I will do so with that page.
Verified fixed on:
-build: Firefox for Android 23.0a2 (2013-05-16)
-device: Samsung Galaxy Nexus
-OS: Android 4.1.1
tracking-fennec: ? → ---
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.