Fixed-width overrides NOWRAP

VERIFIED DUPLICATE of bug 97619

Status

()

Core
Layout: Tables
VERIFIED DUPLICATE of bug 97619
17 years ago
7 years ago

People

(Reporter: Eric A. Meyer (dead account), Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
In the top table, the width has been set to 595 (pixels) through the HTML
attribute WIDTH.  The images total 596px in width, however, thus causing
wrapping of the images within cells and thus shattering the layout.  The cells
have been given the HTML attribute NOWRAP, and NN4.x as well as IE will increase
the size of the table rather than wrap contents of the NOWRAP cells.  This is
probably the best solution for Mozilla as well, at least while in Quirks mode. 
This bug has also led to problems on Web sites like Gateway, so it's fairly
important that we fix this.  Just so you know, changing the width of the table
to match its contents fixes the problem (and I'll be evangelising this solution
to NASA shortly), but that's not really relevant: there's still a problem here,
mostly in that we do something which legacy authors won't expect.

I realize this is similar to the problems described in bug 21025 and bug 71596,
but this report is not quite the same as those reports-- although I suspect they
may all be related.

When in Strict mode, then I believe the table should be the defined size and the
cell contents shouldn't wrap, but instead be displayed according to the value of
'overflow' for the given situation.  (But that's a different discussion...)
(Reporter)

Comment 1

17 years ago
Correction to above: I meant bug 31025, not 21025.  Apologies for any confusion.

Comment 2

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Reassigning to alexsavulov. This sounds like a block issue.
Assignee: karnaze → alexsavulov

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 97619 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
 This bug was fixed and there is no problem with the given URL. Verified on 
2002010903 WIN2K
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.