Left/Right clicks undiscriminated for double-clicks

RESOLVED FIXED in mozilla1.0.1

Status

()

Core
Event Handling
RESOLVED FIXED
17 years ago
2 years ago

People

(Reporter: Dwayne, Assigned: joki (gone))

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.0.1
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build 2001-06-09-20, Win2k sp2

Steps to reproduce:
1. Open MailNews
2. Left, then right click (in quick succession) on a folder name or message.

Result:
New folder/message view opens.

Expected:
Context menu should appear.

Reproduceability:
Always

I have a habit of left clicking on things to ensure they're selected before I
try to pull up context menus.  This habit results in a double-left-click, which
is not what should be expected!

If I knew of another test case where double clicking was required for an action
in, say, the browser, I would have filed it there first.  But I can't think of any!

Comment 1

17 years ago
I can reproduce this in the browser (Win 95 build 2001061804). Double-clicking
on text in the browser causes the whole word to be highlighted. Left-clicking
and then immediately right clicking will cause this to happen to. I just did it
half a dozen times on the text of this bug report. It is a little tricky to do,
probably because of the pop-up menu that appears whenever you right click, but
just keep trying it, you will be able to do it.

Comment 2

17 years ago
Confirm build 2001061804 win32 win98
I see the same effect in MailNews folder pane

I found that if I right click and then left click in the history sidebar panel I
get the same effect as a doubleclick too.
(Reporter)

Comment 3

17 years ago
Hmm, I can also double-right click to do the same thing in the sidebar.

So we have double click, left-right, right-left, and double-right-click all
having the same effect in many cases...

However, I can only get double-click to act as a double-click for selecting text.

Changing summary.
Summary: Left-Right Click acts as Double-Click → Left/Right clicks undiscriminated for double-clicks
Status: UNCONFIRMED → NEW
Ever confirmed: true
actually, over to events.
Assignee: sspitzer → joki
Component: Mail Window Front End → Event Handling
Product: MailNews → Browser
QA Contact: esther → madhur
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Updated

17 years ago
Blocks: 91338

Comment 5

16 years ago
nom'ing 0.9.5.
Keywords: mozilla0.9.5

Comment 6

16 years ago
May have been fixed by fix of bug 71705. Cf "Jesse Ruderman 2001-09-16 00:12".
Keep in mind that bug 71705 may have created new bug 102839.
*** Bug 103570 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
*** Bug 114330 has been marked as a duplicate of this bug. ***
*** Bug 116782 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 118958 has been marked as a duplicate of this bug. ***
*** Bug 119458 has been marked as a duplicate of this bug. ***
*** Bug 120090 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
This error concerns "Manage Bookmark" likewise. 
Perhaps the target milstone and severity should be considered. 
*** Bug 120928 has been marked as a duplicate of this bug. ***
*** Bug 120961 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
using win32 full installer build 2002012403.

curiously enough, in manage bookmarks, a left-click followed quickly by a
right-click will result not only in the bookmarked page being opened in the
browser, but will also open the relevant context menu.  furthermore, while the
manage bookmarks window is sent to the background when this occurs, the context
menu retains focus and is fully active.
*** Bug 122938 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 122995 has been marked as a duplicate of this bug. ***
*** Bug 124301 has been marked as a duplicate of this bug. ***
Keywords: mozilla0.9.5

Comment 21

16 years ago
wfm, build 2002032803, w2k

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Comment 22

16 years ago
*** Bug 150631 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 23

16 years ago
Still happening ... all the way through 1.1beta.

It seems as though it only happens if the context menu (right click) doesn't
come up, or if you're faster than it.  That's very likely with my click speeds.
I find this hard to reproduce in the mail window as well as in the browser. When
I have a left click immediately followed by the right click, I usually get the
context menu come up and if the mouse is over a word, occasionally the word is
selected and then the context menu  comes up. 

Comment 25

15 years ago
Looks like it got fixed somewhere along the line.
(Reporter)

Comment 26

15 years ago
Well, the original, reported behavior is gone, so I will mark this fixed.

HOWEVER, you can still right-left click extremly quickly (almost a combo-click)
in the mailnews area.  But that's being very nitpicky and not conducive to
fixing important bugs, so I'll drop the argument.  :)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
QA Contact: rakeshmishra → trix

Comment 27

14 years ago
Fixed for trees, but not fixed for other stuff (bug 217560).
You need to log in before you can comment on or make changes to this bug.