[Dialer] numbers starting with 5 retrive wrong phone number suggestions

RESOLVED FIXED

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: rexboy, Assigned: gwagner)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-testsuite +
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, firefox21 wontfix, firefox22 wontfix, firefox23 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

(Whiteboard: [fixed-in-birch], )

Attachments

(3 attachments, 1 obsolete attachment)

STR:
1. Open contact app
2. Add a contacts with the following number:
  06505606260
  6518421189
  06575949253
  06509388785
3. Press home to go back to homescreen
3. Open dialer app
4. Type in "565"

Expected result:
 - None of the contacts above are listed in suggestion bar.

Actual result:
 - All of the contacts above are listed.

Reproductivity:
100%

We need to handle follow-up issues after suggestion-bar, or bug 838017, landed. Because suggestion bar just make use of the underlying Contact API, this may need to be fixed from Gecko side.
Priority: P1 → --
Assignee

Comment 1

6 years ago
(In reply to KM Lee [:rexboy] from comment #0)
> STR:
> 1. Open contact app
> 2. Add a contacts with the following number:
>   06505606260
>   6518421189
>   06575949253
>   06509388785
> 3. Press home to go back to homescreen
> 3. Open dialer app
> 4. Type in "565"
> 

Where does this happen? Device (with or without sim card) or desktop?
If we have no information about the current country code we set Brazil as the default country and you can find the contacts because the intl version of the numbers start with +55.
Gregor, device. it's not easy to understand what relation is between query and results for this case when you search phone number on dialer, please see attachment.

root cause is we don't have enough information to highlight matched letters because search detail is hidden beyond gecko.
Assignee

Updated

6 years ago
Blocks: b2g-contact
triage: blocking+, functional breakage on new 1.1 feature.
blocking-b2g: leo? → leo+
This also occurs in the SMS app when searching for contacts using the "To:" field.
Assignee

Comment 5

6 years ago
Posted patch patch (obsolete) — Splinter Review
Assignee: nobody → anygregor
Assignee

Updated

6 years ago
Depends on: 866135
Assignee

Comment 6

6 years ago
Posted patch patchSplinter Review
Attachment #743380 - Attachment is obsolete: true
Assignee

Updated

6 years ago
Attachment #743383 - Flags: review?(reuben.bmo)
Attachment #743383 - Flags: review?(bent.mozilla)
Attachment #743383 - Flags: review?(bent.mozilla) → review+
Attachment #743383 - Flags: review?(reuben.bmo) → review+
Assignee

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/projects/birch/rev/6d7b2b4302b3
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-birch]
https://hg.mozilla.org/mozilla-central/rev/6d7b2b4302b3
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee

Comment 9

6 years ago
Posted patch b2g18 patchSplinter Review
Please land together with patch in bug 866135.
Flags: in-moztrap?

Updated

6 years ago
Flags: in-moztrap? → in-moztrap+

Updated

6 years ago
You need to log in before you can comment on or make changes to this bug.