Font alignment problem in PDF viewer

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: michael, Unassigned)

Tracking

20 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-linux], URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

I opened the following PDF file using the built-in viewer:

http://www.csee.usf.edu/~labrador/Share/workshops/papers/p291-benton.pdf


Actual results:

The vertical alignment of the characters is wrong, as shown in the first screenshot: they seem to hang from the line above rather than sitting on the line below.

http://i.imgur.com/IsYjubr.png


Expected results:

The characters should have been aligned as shown in the second screenshot, which comes from Evince.

http://i.imgur.com/8JOFnpI.png
(Reporter)

Updated

6 years ago
Component: Untriaged → PDF Viewer
(Reporter)

Comment 1

6 years ago
Another PDF that triggers the same bug:

http://conferences.sigcomm.org/sigcomm/2012/paper/sigcomm/p83.pdf
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0 - release
Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0, 21beta5, build ID 20130425162858
Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20130425 Firefox/22.0, build ID 20130425004014 - latest Aurora
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130425 Firefox/23.0, build ID 20130425030845 - latest Nightly

WFM with the latest builds across all branches.

Michael, can you please try in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode) and with a new profile (https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles) and see if it still reproduces on your side?
Thanks!
Flags: needinfo?(michael)
(Reporter)

Comment 3

6 years ago
Thanks for looking into this! I can reproduce the bug in safe mode and with a fresh profile. My user agent is Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0. I'm running Debian Squeeze, but using the latest Firefox, not the one included with Squeeze. Could it be related to the fonts I do/don't have installed?
Flags: needinfo?(michael)
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-linux]

Comment 4

6 years ago
I can confirm this on "Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0".

I remember that the first release of Firefox that supported pdf natively actually seemed to work.
I wasn't able to reproduce the issue on Firefox 20.0.1, Linux 64-bit.

Do you still have this issue on latest Firefox release, Fx 24?
How about latest Nightly? http://nightly.mozilla.org/

Thank you.
Flags: needinfo?(michael)
(Reporter)

Comment 6

5 years ago
I can confirm that the issue is fixed in Firefox 24. Thank you!
Flags: needinfo?(michael)
Thanks for your answer. I'll mark it as RWFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.