Use proper compartment when deserializing ArrayBuffer from parent process

RESOLVED FIXED in mozilla23

Status

()

Core
DOM
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jdm, Assigned: jdm)

Tracking

unspecified
mozilla23
x86_64
Linux
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

Details

(Whiteboard: [fixed-in-birch])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

5 years ago
Without this, the email app remains broken.
(Assignee)

Comment 1

5 years ago
Created attachment 740818 [details] [diff] [review]
Use unwrapped content window object to determine compartment when creating new ArrayBuffers for use by content from TCPSocket. r=
(Assignee)

Updated

5 years ago
Assignee: nobody → josh
Thanks, I can confirm the patch fixes email on my Nexus S too.
(Assignee)

Comment 3

5 years ago
Comment on attachment 740818 [details] [diff] [review]
Use unwrapped content window object to determine compartment when creating new ArrayBuffers for use by content from TCPSocket. r=

For reference, useWin comes from unwrapping (http://hg.mozilla.org/mozilla-central/annotate/acf388eaf9e9/dom/network/src/TCPSocket.js#l306) the window provided as part of nsIDOMGlobalPropertyInitializer.init.
Attachment #740818 - Flags: review?(bzbarsky)
Yeah, confirmed on unagi for v1-train too.  Thanks, Josh!
Comment on attachment 740818 [details] [diff] [review]
Use unwrapped content window object to determine compartment when creating new ArrayBuffers for use by content from TCPSocket. r=

r=me
Attachment #740818 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/projects/birch/rev/5a62b421e490
Whiteboard: [fixed-in-birch]
(Assignee)

Comment 7

5 years ago
Build fix for non-b2g18: https://hg.mozilla.org/projects/birch/rev/86018e20f5c8
Blocks: 863807
(Assignee)

Comment 9

5 years ago
Created attachment 740870 [details] [diff] [review]
Use unwrapped content window object to determine compartment when creating new ArrayBuffers for use by content from TCPSocket.

b2g18 patch.
(Assignee)

Updated

5 years ago
Attachment #740818 - Attachment is obsolete: true
(Assignee)

Comment 10

5 years ago
Created attachment 740917 [details] [diff] [review]
Use unwrapped content window object to determine compartment when creating new ArrayBuffers for use by content from TCPSocket.

Updated b2g18 patch.
(Assignee)

Updated

5 years ago
Attachment #740870 - Attachment is obsolete: true
(Assignee)

Comment 11

5 years ago
And https://hg.mozilla.org/projects/birch/rev/761a78c8ab03 because, yeah, running tests is good.
Needed for bug 863770 which is tef+ so tef+ here, too.
blocking-b2g: tef? → tef+
I uplifted patched 1, 3, and 4 to mozilla-b2g18 which are equivalent to the updated b2g18 patch here on the bug after running tests.  (Patch 2 was a fix for m-c for a patch made for 18.)  This was done for maximum correspondence, but done as a push so push-aware bisection should be happy.

https://hg.mozilla.org/releases/mozilla-b2g18/rev/6809f965cdd7
https://hg.mozilla.org/releases/mozilla-b2g18/rev/d51b1bb27054
https://hg.mozilla.org/releases/mozilla-b2g18/rev/2376197bf4de

I'll uplift to v1.0.1 once it's clear that a git mirror derived build is 100% happy with this and TBPL remains equivalently happy.
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → affected
You need to log in before you can comment on or make changes to this bug.