User is only offered Credit card payments option after setting APN proxy

RESOLVED WONTFIX

Status

Marketplace
Payments/Refunds
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: krupa, Unassigned)

Tracking

All
Gonk (Firefox OS)
Points:
---

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Set APN proxy (10.138.255.133:8080) for Data connection and reboot

steps to reproduce:
1. Start app purchase on marketplace stage
2. Enter PIN


expected behavior:
Confirm purchase screen with carrier billing loads

observed behavior:
Purchase screen with credit card screen loads. user is not provided with credit card screen.
Created attachment 740822 [details]
mobile-id-credit-card-http.log

Here's an http request/response log when MobileID detects a numbers and redirects to a credit card screen (instead of a mobile bill screen)
Created attachment 740823 [details]
screenshot.png

screenshot of credit card screen
I think this is intended behavior because the region was set to the US on marketplace. When setting the region to Spain, the mobile billing worked. This is because when out of region Bango switches to credit card payment
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.