Firefox 20.0.1 *constantly* crashing from any drag & drop action

RESOLVED INVALID

Status

()

Firefox
Shell Integration
--
critical
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Lawrence, Unassigned)

Tracking

({crash})

20 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Any drag & drop action seems to be causing FF to crash. I've had it happen in at least the following situations:

- Drag a tab to change position (when multiple tabs are open)
- Drag a tab from one window to another
- Drag a file into a FF window (i.e. when trying to add an attachment in google mail using drag and drop)
- Drag a URL into a separate window to try to open that url in that window
- Drag text selected in a text input field (i.e. while in a form, select text within an input type=text form element, then click to drag that text)
- Drag text selected in other elements (this has happened to me when using an online code editor (from Salesforce) ... normally you can select a block of code and drag it to a different place in the code)

In all cases FF crashes *immediately* at the click-to-drag (click and hold?) or immediate start of the drag -- there is no perceptible time between the click-to-drag action and the crash, however normal click-to-click (on a link or a tab for example) does not case FF to crash.

This happens in safe mode as well.

This started happening as soon as 20.0.1 was installed. Before this new version I had no trouble with drag & drop. Now it happens constantly throughout the day.

I've submitted numerous crash reports, one primary one (in case it's not automatically attached) is:
https://crash-stats.mozilla.com/report/index/bp-a6330003-9d00-4130-80b3-092422130423


The most easily reproduced instance is the first one listed above - the drag a tab crash. Steps to reproduce are:

- Open FF (for me Google opens as my home page in a single tab)
- Click the '+' sign to open a new tab (opens empty)
- Click on the original tab (the one with Google in it) to drag it to be after the second tab



Actual results:

Firefox crashes as soon as the click-to-drag action takes place.


Expected results:

The drag should have happened.

Comment 1

5 years ago
You are the only user amongst 400M ones to crash with this signature (see ttps://crash-stats.mozilla.com/report/list?signature=xul.dll%400xf7bf20+|+UserCallWinProcCheckWow) or on dragging at least reported in Bugzilla. 

It's caused by HookDLL.dll, an unversioned DLL. Check for malware (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-caused-malware#w_how-do-i-prevent-malware-from-being-installed) and report back.
You should have check out https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help before reporting it.

(In reply to Lawrence from comment #0)
> in case it's not automatically attached
You need to click Report this bug in Firefox inside the crash report for that.
Severity: normal → critical
Crash Signature: [@ xul.dll@0xf7bf20 | UserCallWinProcCheckWow ]
Component: Untriaged → Shell Integration
Flags: needinfo?(lawrence.coffin)
Keywords: crash
(Reporter)

Comment 2

5 years ago
Thanks Scoobidiver, that version of HookDLL.dll appears to be a .dll that comes with a tool called Virtual Dimension that I've used since 2008. After stopping and restarting Virtual Dimension, drag & drop in FF appears to be working now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(lawrence.coffin)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.