Closed Bug 864867 Opened 8 years ago Closed 8 years ago

[Email] When mail body is larger than 4k, the fetch of the remainder of the body forgets the already-retrieved first 4k.

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

RESOLVED FIXED
blocking-b2g tef+
Tracking Status
b2g18 --- fixed
b2g18-v1.0.1 --- fixed

People

(Reporter: gerard-majax, Assigned: jlal)

References

Details

(Whiteboard: QARegressExclude)

Attachments

(8 files)

On gaia master from today, d092d01, I'm getting issues with HTML rendering on some mails: parts of the mail disappears.
blocking-b2g: --- → tef?
Attached image Europcar mail part 1
Attached image Europcar mail part 2
Attached file Europcar HTML source
Attachment #740913 - Attachment description: Eurocar HTML source → Europcar HTML source
Summary: [Email] HTML rendering getting weird, eating parts of the text → [Email] Rendering getting weird, eating parts of the text
Attached file ADVCOMP mail source
It seems it is not limited to HTML mails ... See this one. (screenshot next)
Attached image ADVCOMP mail rendering
Remember this one is text only ...
Could there be some link with bug 864775 and bug 831107 ?
As being asked on IRC, this does not seems to be related to my IMAP server; I'm reproducing it also from a Gmail account with the same email. Please note that the cutting occurs roughly at the same place (delta is around 10 characters).
Are you using v1.0.1 or v1.1 code?  I noticed something funny in regards to line breaks for Japanese as well : bug 862607

Can you try with code from master?
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #9)
> Are you using v1.0.1 or v1.1 code?  I noticed something funny in regards to
> line breaks for Japanese as well : bug 862607
> 
> Can you try with code from master?

As stated in comment #1, I'm using master from yesterday, commit d092d01.
blocking-b2g: tef? → leo?
traige: leo+, bad html rendering problem making it difficult to read emails
blocking-b2g: leo? → leo+
(In reply to Joe Cheng [:jcheng] from comment #11)
> traige: leo+, bad html rendering problem making it difficult to read emails

Please, this is not limited to HTML rendering, it also hits plain text.
Duplicate of this bug: 866896
To clarify, this indeed will affect all types of e-mails.  It's just that it's much more likely that HTML emails will exceed 4k in size.
Summary: [Email] Rendering getting weird, eating parts of the text → [Email] When mail body is larger than 4k, the fetch of the remainder of the body forgets the already-retrieved first 4k.
Yeah this is my fault... I will pick this up after my other tef+ bug (next 1-3 days). Not assigning myself yet.
Attachment #743300 - Flags: review?(bugmail)
OK I lied... simple fix.
Assignee: nobody → jlal
Attachment #743300 - Flags: review?(bugmail) → review+
This *really* wants a tef+ uplift.  Display of e-mails larger than 4k is fundamentally broken without this fix.  If you don't want it on tef, please give us back our leo+.
blocking-b2g: leo+ → tef?
blocking-b2g: tef? → tef+
Uplifted 5944dfb3fb724755fde23d6cccb0f1bfa218e065 to:
v1-train: 3cb40c1c44d26d0705a3c317861174c21f3e4b2c
v1.0.1: 59d8c2e750490679765b447e43bb77a80a3f9f39
Can you please provide steps to verify this fix - as we will blackbox test from the UI?
(In reply to croesch from comment #21)
> Can you please provide steps to verify this fix - as we will blackbox test
> from the UI?

The test I described on https://bugzilla.mozilla.org/show_bug.cgi?id=857900#c8 is the same thing you would want to test here; this bug fixes a bad regression from that bug.  Since that was QARegressExclude, I'll mark that on this too.
Whiteboard: QARegressExclude
Duplicate of this bug: 873922
You need to log in before you can comment on or make changes to this bug.