Last Comment Bug 864871 - Fix for Bug 743252 is incomplete - top margin is still being adjusted
: Fix for Bug 743252 is incomplete - top margin is still being adjusted
Status: RESOLVED DUPLICATE of bug 847049
[pdfjs-c-other][pdfjs-d-printing]
:
Product: Firefox
Classification: Client Software
Component: PDF Viewer (show other bugs)
: 22 Branch
: x86 Windows 7
: P3 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Brendan Dahl [:bdahl]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-23 10:24 PDT by Deanna Foster
Modified: 2013-05-08 01:06 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
PDF formatted for label printing has too much top marging after FF18.pdf (919.38 KB, application/pdf)
2013-04-23 10:24 PDT, Deanna Foster
no flags Details
Scanned Print: Stamplabels.pdf printed onto sheet of self-adhesive labels, directly from FF (spoilt by PDFjs rescaling) (1.38 MB, application/pdf)
2013-04-26 14:57 PDT, Deanna Foster
no flags Details
Labels printed from PDF which was saved first (919.36 KB, application/pdf)
2013-04-26 14:58 PDT, Deanna Foster
no flags Details
Testcase: Original PDF file with stamps for label printing (919.36 KB, application/pdf)
2013-05-07 12:06 PDT, Deanna Foster
no flags Details
This was printed directly from Mozilla to labels loaded in printer. Resulting hard copy was scanned. See comments in PDF. (1.38 MB, application/pdf)
2013-05-07 12:08 PDT, Deanna Foster
no flags Details

Description Deanna Foster 2013-04-23 10:24:51 PDT
Created attachment 740909 [details]
PDF formatted for label printing has too much top marging after FF18.pdf

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Mozilla fixed the problem with the page URL printing on the PDF (bug Fix for Bug 743252).  However, the margin has not been reverted back to what it was before the page URL printing was introduced.  So, the URL was removed, but not the margin adjustment that was made to support the URL.


Actual results:

Users of our application are printing onto labels from the PDF displayed in the Firefox PDF viewer.  Label printing is very precise.   When the URL printing was introduced, users could no longer print to their labels using Firefox, as the alignment was now off - being pushed down by the new header.  We have had to advise our customer to tell their users to use another browser or change their default PDF viewer, which introduces additional support issues.    Bug 743252 fixed part of the problem by suppressing the URL printing, but the top margin was not set back to what it was before Firefix 18.


Expected results:

In order for users to resume printing labels using the Firefox PDF viewer, we need to have the top margin adjusted to what it was before the URL printing in the header was introduced in FF18.   This will return the alignment of the labels back to normal.
Comment 1 Loic 2013-04-24 04:23:18 PDT
I tried to print from the PDF Viewer to the local printer MS Document XPS, the result is the same (top margin) if I download the PDF then I print it from my local PDF Reader.

Could you upload printed PDF, please.
Comment 2 Deanna Foster 2013-04-26 14:57:11 PDT
Created attachment 742572 [details]
Scanned Print: Stamplabels.pdf printed onto sheet of self-adhesive labels, directly from FF (spoilt by PDFjs rescaling)

Notice on this PDF, how the images on the PDF are slightly "shrunk", resulting in alignment issues.  The stamps do not align with the labels after the first row.
Comment 3 Deanna Foster 2013-04-26 14:58:25 PDT
Created attachment 742574 [details]
Labels printed from PDF which was saved first

This PDF was downloaded from the application, and then printed from Adobe.  Notice how the stamps line up exactly with the labels.
Comment 4 Deanna Foster 2013-04-26 14:59:12 PDT
Comment on attachment 742572 [details]
Scanned Print: Stamplabels.pdf printed onto sheet of self-adhesive labels, directly from FF (spoilt by PDFjs rescaling)

Note:  as there was no way to create a PDF from a direct print, I printed this PDF onto the labels, and then scanned the resulting print-out.
Comment 5 Deanna Foster 2013-04-26 15:03:58 PDT
Note:  we have dozens of users in France who upgraded their Firefox versions and experienced the URL printing in the margins causing their stamps to "shrink to fit" the larger margins.  We were hoping with the removal of the URLs that the "shrink" problem would also go away, but apparently it hasn't.

We had out primary testers in France try your latest version as well, so we know it's not a problems specific to a particular browser installation or printer.

They are a very large organization, hence this is having a big impact on not only their users, but their first level support as well.  So, we're really hoping for a solution that doesn't involve the users having to reconfigure their browsers (they are not that technical).
Comment 6 Deanna Foster 2013-04-29 15:17:21 PDT
This may be a duplicate of bug 847049.  Please advise if this bug should be merged into 847049.
Comment 7 Deanna Foster 2013-05-07 09:54:33 PDT
I have merged the attachments and comments into bug 847049.  This can be closed as a duplicate.
Comment 8 Deanna Foster 2013-05-07 09:55:12 PDT

*** This bug has been marked as a duplicate of bug 847049 ***
Comment 9 Thomas D. (needinfo?me) 2013-05-07 11:30:49 PDT
Deanna, thanks for duping, well done & thanks for providing another more-than-relevant and frequent use case / scenario.

I'll start here to understand your attachments and tweak descriptions a little before doing the same on the other bug. Just ignore.
Comment 10 Thomas D. (needinfo?me) 2013-05-07 11:43:58 PDT
It's not easy to understand which is which...

(In reply to Deanna Foster from comment #3)
> Created attachment 742574 [details]
> Labels printed from PDF which was saved first
> 
> This PDF was downloaded from the application, and then printed from Adobe. 

Hmmm. Is this the original pdf file from which users are supposed to print?
Or did you print the original via Adobe into another ("printed") pdf?

> Notice how the stamps line up exactly with the labels.

I don't see the labels, so it's not easy to notice...
Deanna, can you do this pls:

Attach the original pdf file as received from stamps application (if you haven't already), and describe clearly as original.

Attach a scanned copy of the printout you'll get when printing the original pdf onto labels, using adobe reader, so that devs can see the difference to FF printout more easily. Add annotations / pen markings as you did where necessary. Thanks.
Comment 11 Deanna Foster 2013-05-07 12:03:08 PDT
Regarding:  Labels printed from PDF which was saved first:  The PDF was saved directly from the web application, and then opened with Adobe and printed.  When I use native Adobe to print the PDF, it's perfect.  Do you want me to relabel the PDF?

For the one that was printed directly from Firefox, I scanned the hard-copy after printing on the labels.  I agree the labels are hard to see, but you can see the alignment difference relative to the one printed directly from PDF.

Do you want me to "print to PDF" from Mozilla instead of scanning the printed hard-copy?  (you still won't be able to see the labels, since they are physical, but it can be compared to the Adobe-printed version.
Comment 12 Deanna Foster 2013-05-07 12:06:37 PDT
Created attachment 746561 [details]
Testcase: Original PDF file with stamps for label printing
Comment 13 Deanna Foster 2013-05-07 12:08:43 PDT
Created attachment 746562 [details]
This was printed directly from Mozilla to labels loaded in printer.  Resulting hard copy was scanned.  See comments in PDF.
Comment 14 Deanna Foster 2013-05-07 12:13:22 PDT
Hi Thomas.  I removed the PDFs, renamed the relevant ones, and re-uploaded them. So now there are two samples:
1) PDF saved to hard drive, then opened and printed with Adobe Reader (alignment perfect)
2) PDF printed directly from Mozilla onto labels.  See comments in the PDF.  This one has alignment issues (images too small,etc.)   The labels are hard to see (they show up as a slight gray shadow).  if you compare the two PDFs, you will see the difference in the alignment.  

Let me know if this helps.  FYI, this is A4 paper, as the application is used in France.
Comment 15 Thomas D. (needinfo?me) 2013-05-07 12:56:49 PDT
(In reply to Deanna Foster from comment #14)
> Hi Thomas.  I removed the PDFs, renamed the relevant ones, and re-uploaded
> them. So now there are two samples:
> 1) PDF saved to hard drive, then opened and printed with Adobe Reader
> (alignment perfect)

This is the original pdf file as you received it from the stamping application, right? Can you confirm each of the following?
a) did you download the file directly to your hard drive?
b) for downloading, you did NOT use Ctrl+S in FF-pdfjs-viewer, i.e. you DID use the pdfjs download button, or "Save link as..."?
c) you then attached the file here directly without further processing or modification?

> 2) PDF printed directly from Mozilla onto labels.  See comments in the PDF. 
> This one has alignment issues (images too small,etc.)   The labels are hard
> to see (they show up as a slight gray shadow).  if you compare the two PDFs,
> you will see the difference in the alignment.  
> 
> Let me know if this helps.  FYI, this is A4 paper, as the application is
> used in France.

Could you add a scanned pdf of the *correct* physical printout on *label sheet*?
Comment 16 Thomas D. (needinfo?me) 2013-05-07 13:00:19 PDT
(In reply to Thomas D. from comment #15)
> Could you add a scanned pdf of the *correct* physical printout on *label
> sheet*?

so that's
- open unmodified, original stamps.pdf file with *adobe reader*
- print it from adobe reader to your printer on adhesive labels
- scan the printed copy into a pdf file
- attach that file here
Comment 17 Thomas D. (needinfo?me) 2013-05-08 01:05:15 PDT
Comment on attachment 746561 [details]
Testcase: Original PDF file with stamps for label printing

I understand that this is the *original* PDF file with stamps positioned correctly for printing on label sheet.

- when printed with Adobe reader -> good (each stamp correctly positioned on one label)
- when printed with FF -> bad (stamps are shrunk and printed across labels, thus spoiling the whole sheet)

Note You need to log in before you can comment on or make changes to this bug.