Closed Bug 865097 Opened 9 years ago Closed 9 years ago

Trying to add a photo to a Facebook status post does nothing

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 843877

People

(Reporter: simon.callan, Unassigned)

Details

(Whiteboard: [apps watch list1])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31

Steps to reproduce:

Try to update you status. Click on the camera icon


Actual results:

It just shows a text box - you can type free form text into it, but nothing happens


Expected results:

Should allow you to chose a photo from your gallery, or use camera
ZTE OPEN
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [apps watch list1]
As far as I know, this feature is not finished yet...?
Component: General → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk
During previous tests by the app review team, all photo upload actions advised the user that this feature isn't supported yet, and gave a custom email address that could be used to send photos.  Notifying developer of regression.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(In reply to Lisa Brewster [:adora] from comment #3)
> During previous tests by the app review team, all photo upload actions
> advised the user that this feature isn't supported yet, and gave a custom
> email address that could be used to send photos.  Notifying developer of
> regression.

Umm...I'm seeing an email address on my account. The browser support issue is already known - facebook relies on using DOM input=file and hasn't moved to adding support here.

So no, this isn't a regression I'm seeing from my end - as Kevin cites, this is still the same issue we've known all along for a long time even back in FxAndroid days.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 709742
Actually, wrong bug.

This is going to be solved when we pull out the UA override in bug 843877.
Duplicate of bug: 843877
A bit more detail:

Facebook in a FxAndroid context switches over to a new status post layout that actually supports photo uploads. However, FxOS doesn't support this functionality in 1.01 and we've still got the old override left behind, so we end up with a partially non-functional UI in that case.

If you switch the UA to the FxOS UA, you'll notice we're going to get the old behavior we used to see. So this is solved when we uplift bug 843877.

But please, do not message the developer on this one. This will cause a regression on FxAndroid if you do.
So what's the outcome of this - the app doesn't work on the FFOS devices we are going to launch- and posting photos is a key use case so will this work by time devices launch in 8 weeks?
Thanks
(In reply to Simon Callan, Telefonica from comment #7)
> So what's the outcome of this - the app doesn't work on the FFOS devices we
> are going to launch- and posting photos is a key use case so will this work
> by time devices launch in 8 weeks?
> Thanks

Yes, the app has it's issues. We've got a list of issues all bucketed off the facebook.com meta bug - bug 759986. We've made strong progress to get a lot of issues resolved, however (i.e. it was a lot worse months back - we were getting outdated web content).

The input=file option is out as a choice to solve this problem for 1.01 completely given that we don't support that functionality. The best possible option we've got here is that we would tell facebook to use web activities if they exist on a FF OS user agent only to get photo uploads. Otherwise, we'll remain with the same issue we've known for a while on FxAndroid of being unable to upload photos directly from the phone and having to email them instead.
Note for discussion on comment 8 - that's more relevant to bug 709742.
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.