JavaScript which I save in the bookmark location field is truncated

RESOLVED DUPLICATE of bug 604374

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 604374
5 years ago
4 months ago

People

(Reporter: Joshua J. Gomes, Unassigned)

Tracking

21 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

I entered JavaScript over 65,535 characters long in a bookmark location field.  I restarted Firefox.


Actual results:

The bookmark location field is truncated and shortened to 65,535 characters each time I restart Firefox.  This causes the script to no longer work since it is cut off.  I have to paste the script back into the location field and re-save it to make it work again.  This does not happen with Google Chrome.


Expected results:

I should be able to enter any length of JavaScript into the bookmark location field so I can go about my day happily automating tasks on the internet.  I should not need to re-enter and save the JavaScript each time I restart Firefox.

I have requested this several times as a feature request but with each new version of Firefox released there is no improvement.

Please, please fix with the next version!  If not fixed then I will need to start using Chrome exclusively and I don't want to do that.  I want to use Firefox which I have used for years but it is getting harder with all the scripts I run now.  Please help!

Comment 1

5 years ago
Could you post the JS chain, so we'll be able to test.
Flags: needinfo?(joshgomes)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604374

Updated

5 years ago
Component: Untriaged → Bookmarks & History
(Reporter)

Comment 3

5 years ago
(In reply to Loic from comment #1)
> Could you post the JS chain, so we'll be able to test.

Here is a link to a sample script that exhibits the same behavior:

http://www.techsleuth.com/firefox.issue/javascript.test.js

Just curious, why was this marked as resolved?  It is not resolved.  This is not a duplicate of the other bug 604374.  This bug refers to JavaScript URLs and that bug is about something else.

JavaScript use would be unlimited for advanced users if it actually worked properly like it does in Chrome.  Some users may not use JavaScript but a lot more of us do each day.  I really need this to work, and there is no reason I know of for it not to work.  Please reopen so it can be addressed!
Flags: needinfo?(joshgomes)

Comment 4

5 years ago
> This is not a duplicate of the other bug 604374.  This bug refers to JavaScript URLs and that bug is about something else.

I think it's the same field, and stored the same way, and the limitation does not depend on the type of the URI?
(Reporter)

Comment 5

5 years ago
Sad day today.  I have been a loyal FireFox user for 12 years or so.  But I am now switching to use Google Chrome as my main browser.  At least until this fixed.  I do not want to do but I have no choice.  I opened this bug report but someone closed it and marked as duplicate of 604374 although I do not feel it is truly a duplicate of that bug.  I really need my JavaScripts to work properly without what is now adding up to be so much wasted time.  It is becoming unbearably annoying to have to paste them in over and over again every time I restart the browser.  I am at my wits end here.  Can someone please let me know, is there a limitation with FireFox architecture that prevents this from being solved?  If not, can someone please either fix or give me access to fix it?  Thank you!

Comment 6

5 years ago
Did you try to save the bookmarklet as minified JS code?
(Reporter)

Comment 7

5 years ago
Yes same thing happens with the code minified.  It is still truncated in the same way.  The same thing happens with Firefox version 21.  I decided I would be glad to work on this in my spare time.  I am an experienced programmer.  It seems like it may be an easy fix.  Can someone please give me access or point me to information on where to get started with working on Firefox?  It would be great to be able to get this fixed and use it as my main browser again.  Thanks!
Severity: normal → major
Version: 20 Branch → 21 Branch

Comment 8

2 years ago
(In reply to Joshua J. Gomes from comment #3)
> This is not a duplicate of the other bug 604374. 
I agree. We will not be able to run very long (minified) JavaScript in bookmark even if bug 604374 is fixed (e.g., an error dialog popping up upon input of a very long bookmark, preventing the user from saving it). 
> JavaScript use would be unlimited for advanced users if it actually worked
> properly like it does in Chrome. 
I'd suggest a configurable max URL length for bookmark in about:config, so that novices who do not use bookmarklet or modify about:config will not be affected. To this day, Chrome still handles long bookmarks well and it is a pity that Firefox still cannot.

Updated

2 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
As a developer, I can say this is definitely a duplicate of bug 604374. These are treated the same way and are stored in the same fields.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604374
You need to log in before you can comment on or make changes to this bug.