Bring back the link to return to carrier billing from credit card payment screen

RESOLVED FIXED in 2013-06-13

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Assigned: keir)

Tracking

({regression})

2013-06-13
regression
Points:
---

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Start the purchase flow for a paid app
2. Choose to pay with credit card


expected behavior:
Users have the option to change their mind and return to carrier billing screen. This used to be available in the older bango screens.

observed behavior:
With the new mocks, we got rid of this option. Please consider bringing this option back.
(Assignee)

Comment 1

6 years ago
(In reply to krupa raj 82[:krupa] from comment #0)
> observed behavior:
> With the new mocks, we got rid of this option. Please consider bringing this
> option back.

Please assign to Maureen for consideration.

Comment 2

6 years ago
Created attachment 741458 [details]
Credit Card payment screen

I understand the desire of the user to be able to change their mind and return to carrier billing, however I just don't see how we are going to fit a link into this already extremely crowded screen, especially when it is localized. I think changing the payment method is an edge case (not many people have credit cards, some markets will only be able to use credit cards, etc.) so I'm willing from a UX point of view to require the user to cancel and start the process again. The user will return to the app details page, click the buy button and (since she is already signed in) should be taken to the "Enter pin screen" before she then sees the confirm payment screen and can re-choose their payment method. 

Moving forward to v2 we should consider having a back button as part of the Trusted UI so that users can return to previous screens in the flow. So rather then having to create back links for specific screens the ability to go back is always available to the user.

Updated

6 years ago
Assignee: keir → mhanratty

Comment 3

6 years ago
Created attachment 743271 [details]
Credit Card payment screen with "Go Back" button

Proposing that the "Cancel" button be changed to a "Go Back" button. If the user clicks "Go Back" they should return to the previous Confirm Payment screen where they can choose carrier billing.

In Venezula or countries that do not have the option for carrier billing the button should remain "Cancel"

Comment 4

6 years ago
Above mock was added to Bango flows in this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=856827

Updated

5 years ago
Assignee: mhanratty → keir

Comment 5

5 years ago
should be fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-06-13
You need to log in before you can comment on or make changes to this bug.