Mozilla Persona Home screen loads during app purchase with language=Spanish via Settings app

RESOLVED FIXED

Status

()

Core
Identity
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: jedp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 741282 [details]
logs

steps to reproduce:
1. Set language=Spanish from the Settings app
2. Launch the marketplace stage app as an anonymous user
3. Start purchase of an app
4. Click the Sign in button within the trustedUI

expected behavior:
persona sign in page loads

observed behavior:
Mozilla Persona Home page loads without any CSS styling since GET /production/es/dialog.js is a 404. See additional logs

http request [
GET /production/es/dialog.css HTTP/1.1
Host: login.native-persona.org
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0
Accept: text/css,*/*;q=0.1
Accept-Language: es,es-ES;q=0.8,es;q=0.6,en-US;q=0.4,en;q=0.2
Accept-Encoding: gzip, deflate
Referer: https://login.native-persona.org/sign_in
Connection: keep-alive
]
I/PRLog   (  109): 2013-04-24 13:13:04.069936 UTC - 1074521336[40304160]: nsHttpTransaction::Init [this=47690540 caps=3]
Starting: 47690540
http request [
GET /production/es/dialog.js HTTP/1.1
Host: login.native-persona.org
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0
Accept: */*
Accept-Language: es,es-ES;q=0.8,es;q=0.6,en-US;q=0.4,en;q=0.2
Accept-Encoding: gzip, deflate
Referer: https://login.native-persona.org/sign_in
Connection: keep-alive
]
I/PRLog   (  109): 2013-04-24 13:13:04.264119 UTC - 2859456[40304470]: nsHttpTransaction::HandleContentStart [this=47690260]
Duration:        0.257 47690260       (login.native-persona.org -> GET /production/es/dialog.css)
http response [
HTTP/1.1 404 Not Found
x-powered-by: Express
Strict-Transport-Security: max-age=10886400; includeSubdomains
Content-Type: text/plain
Vary: Accept-Encoding,Accept-Language
x-frame-options: DENY
Access-Control-Allow-Origin: https://native-persona.org
Date: Wed, 24 Apr 2013 13:13:05 GMT
Connection: keep-alive
Transfer-Encoding: chunked
]
I/PRLo
(Reporter)

Comment 1

5 years ago
Created attachment 741285 [details]
screenshot
I think this is an identity bug but not sure who to contact about it.  CCing people!
Component: Payments/Refunds → Identity
Product: Marketplace → Core
Version: 1.2 → unspecified
Assignee: nobody → jparsons
(In reply to Wil Clouser [:clouserw] from comment #2)
> I think this is an identity bug but not sure who to contact about it.  CCing
> people!

Hi, Will, thanks for cc-ing me.  I'll check it out.  Locale 'es' is enabled on native-identity.org ... looking to see what's up
This is fixed and working via my unagi, so ima just close it.  Reopen if need be.  Cheers!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

5 years ago
This bug has resurfaced. reopening so that jed can investigate.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This should be fixed.  The intermittent problem is due to me redeploying an ephemeral instance and not always getting the l10n deploy correct :-/

The good news is that we've changed our browserid deploy script to make this happen automatically now so that operator error should no longer be a culprit.
fixed, then?
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.