Closed Bug 865210 Opened 7 years ago Closed 7 years ago

Set a valid window icon for desktop

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set

Tracking

(b2g18 fixed)

RESOLVED FIXED
Tracking Status
b2g18 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

Details

Attachments

(1 file, 3 obsolete files)

Currently, b2g desktop gets a valid application icon, but no window icon,
so that it appear with an unknown OS default icon in Window and linux taskbars.

Also, the application icon is fennec, we should use another one closer to Firefox OS.
Comment on attachment 741320 [details] [diff] [review]
Set a valid window icon for B2G desktop

I've updated b2g.ico for windows and added a default.png for linux, with the following simulator icon:
https://github.com/mozilla/r2d2b2g/blob/master/addon/icon.png

I've also introduced a DTD, the first "non-override" one, to add a title to the window/app, so that a name can be printed in OS taskbars.
Attachment #741320 - Flags: review?(21)
Attachment #741320 - Attachment is obsolete: true
Attachment #741320 - Flags: review?(21)
Attachment #741435 - Attachment is obsolete: true
Comment on attachment 741445 [details] [diff] [review]
Set a valid window icon for B2G desktop

I removed dtd usage per vivien's request, as it won't be usefull for the device and may introduce regressions.
Attachment #741445 - Flags: review?(21)
Comment on attachment 741445 [details] [diff] [review]
Set a valid window icon for B2G desktop

Review of attachment 741445 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not 100% sure this is a nice logo but let's go for it.
Attachment #741445 - Flags: review?(21) → review+
Whiteboard: [fixed-in-birch]
Unfortunately, the change busted a bunch of builds:

  https://tbpl.mozilla.org/?tree=Birch&rev=0444a6571cac

So I backed it out:

  https://tbpl.mozilla.org/?tree=Birch&rev=29027b21bd19

Here's a sample log:

  https://tbpl.mozilla.org/php/getParsedLog.php?id=22303461&tree=Birch&full=1

And a relevant snippet:

16:53:16     INFO -  copying /data/local/b2g/chrome/icons/default/default.png to /system/b2g/chrome/icons/default/default.png
16:53:16     INFO -  _traceback (most recent call last):
16:53:16     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/emulator.py", line 391, in install_gecko
16:53:16     INFO -      'of=%s' % system_b2g_file])
16:53:16     INFO -    File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/mozdevice/devicemanager.py", line 341, in shellCheckOutput
16:53:16     INFO -      raise DMError("Non-zero return code for command: %s (output: '%s', retval: '%s')" % (cmd, output, retval))
16:53:16     INFO -  DMError: Non-zero return code for command: ['dd', 'if=/data/local/b2g/chrome/icons/default/default.png', 'of=/system/b2g/chrome/icons/default/default.png'] (output: '/system/b2g/chrome/icons/default/default.png: cannot open for write: No such file or directory', retval: '1')
16:53:16     INFO -  Error installing gecko!
...
16:54:52    FATAL - Failed to install gecko 5 times in a row, aborting
16:54:52    FATAL - Exiting -1
Whiteboard: [fixed-in-birch]
Attachment #741445 - Attachment is obsolete: true
Comment on attachment 744554 [details] [diff] [review]
Set a valid window icon for desktop

New patch that try to copy the icon only when building desktop version:
  https://tbpl.mozilla.org/?tree=Try&rev=098cfd46ee2a
Comment on attachment 744554 [details] [diff] [review]
Set a valid window icon for desktop

Tests are green.

This issue make me think that we should have two distinct shell.xul files,
one for the device and another one for desktops that will contain additional desktop paradigms.
We may even go futher and have two distinct xul apps sharing components and modules.
Attachment #744554 - Flags: review?(21)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/27cf86aa4c21
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Comment on attachment 744554 [details] [diff] [review]
Set a valid window icon for desktop

[Approval Request Comment]
Bug caused by (feature/regressing bug #): No regression; this never worked.
User impact if declined: The impact is minor, but both B2G Desktop and the Firefox OS Simulator would continue to lack a customized dock icon on Windows and Linux if this request were to be denied, which is unexpected and seems off to users.
Testing completed: In addition to TryServer and local machine testing, this has been baking on mozilla-central for a week.
Risk to taking this patch (and alternatives if risky): The risk is low (no changes on Gonk), and there are no alternatives.
String or UUID changes made by this patch: None.
Attachment #744554 - Flags: approval-mozilla-b2g18?
Attachment #744554 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
You need to log in before you can comment on or make changes to this bug.