Closed Bug 865267 Opened 8 years ago Closed 3 years ago

Duplicate folders in bookmarks menu when one folder is dragged and dropped into another

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bogdan_maris, Unassigned)

Details

Reproducible on the latest Beta (BuildID: 20130423212553):
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0
Reproducible on the latest Aurora (BuildID: 20130424004015):
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20130424 Firefox/22.0
Reproducible on the latest Nightly (BuildID: 20130424030917): 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20130424 Firefox/23.0

Steps to reproduce:
1. Start Firefox.
2. Open Show All Bookmarks (ctrl/cmd+shift+B).
3. Enter Bookmarks Menu and create one/two new folders.
4. From the side panel drag the folder that`s above into the one below.

Expected results: The folder A is successfully moved into folder B.

Actual results: After dragging folder A into folder B, the focus remains on Folder B and there can be seen two identical folders inside.

Notes:
1. This issue is not a regression: it reproduces back to Firefox 4.0.
2. After focusing another folder or enter another folder, the issue is no longer there.
3. Screencast captured showing the issue: http://www.screencast.com/t/FMPfrPQmTkQi
Does this happen on any other platforms?
Do you see any errors in Error Console?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #1)
> Does this happen on any other platforms?
> Do you see any errors in Error Console?

This happens with Windows XP x32, Windows 7 x64, Windows 8 x32, Ubuntu 12.10 x32, Mac OS X 10.8, and the Error Console is blank.
Summary: Duplicate folders in bookmarks menu when one folder is dragged and dropped intro another → Duplicate folders in bookmarks menu when one folder is dragged and dropped into another
Bogdan, I can't reproduce this on Firefox 58.0.2, is this still an issue for you?
Flags: needinfo?(bogdan.maris)
(In reply to Mark Banner (:standard8) from comment #3)
> Bogdan, I can't reproduce this on Firefox 58.0.2, is this still an issue for
> you?

Nope, not reproducible for me either on Firefox 58.0.2.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(bogdan.maris)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.