Bad sensibility on Browser and some apps

RESOLVED INVALID

Status

Firefox OS
General
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: juanpbf, Unassigned)

Tracking

unspecified
1.0.1 Cert2 (21may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [apps watch list])

(Reporter)

Description

5 years ago
Ikura
gaia commit:
cc0e498 Merge pull request #8186 from jaoo/836257
gecko commit:
2ab9876 Bug 854302 - [Buri][WIFI]Cann't disconnect WIFI when connect AP use WPS. r=mrbkap, a=tef+

Lower toolbar in wikipedia application does not work. When pressing any of the icons on it, there is no response. 
However, searching articles and browsing work perfectly

Updated

5 years ago
Component: General → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk
(Reporter)

Comment 1

5 years ago
This app belongs to the preinstalled Apps for commercial launch, so either this bug is solved or the app is removed from the grid.

Added dependencies with certif. meta
Component: Preinstalled B2G Apps → General
Depends on: 855322, 855378
Product: Tech Evangelism → Boot2Gecko
Whiteboard: [apps watch list1]
Version: Trunk → unspecified
(Reporter)

Comment 2

5 years ago
Nominating to tef?
blocking-b2g: --- → tef?
Per talking with Karen & other associated parties, any bugs in relation to partner apps belong in the tech evangelism component, not the b2g component.
blocking-b2g: tef? → ---
Component: General → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk

Updated

5 years ago
Blocks: 855322, 855378
No longer depends on: 855322, 855378

Updated

5 years ago
Component: Preinstalled B2G Apps → General
Product: Tech Evangelism → Boot2Gecko
Version: Trunk → unspecified
dwatson and I did some digging on this. This is definitely an Ikura-specific bug in Inari builds. Both of us can reproduce this behavior on Inari builds, but can't reproduce this at all on unagi builds.

Probably something busted at the device level, so this isn't an app-specific issue. Noming to block as such.
Status: UNCONFIRMED → NEW
blocking-b2g: --- → tef?
Ever confirmed: true

Updated

5 years ago
blocking-b2g: tef? → tef+
Whiteboard: [apps watch list1] → [apps watch list1][ikura]

Updated

5 years ago
Blocks: 859362

Comment 5

5 years ago
Based on #4, it can be reproduced on Ikura, but can't be reproduced on Unagi. 
Keven, any idea about this? Thank you.
Flags: needinfo?(kkuo)

Comment 6

5 years ago
Hi, all, it looks like this bug needs to be fixed before May 21th(not May 28th). Please correct me if you see something different. Thanks.
Target Milestone: --- → 1.0.1 Cert2 (28may)

Updated

5 years ago
Whiteboard: [apps watch list1][ikura] → [apps watch list1][ikura][POVB]

Comment 7

5 years ago
Talked with Keven, and we suspected that it could be related to touch. In order to make sure about this, we would like to ask for QA's help to have the reproducible environment. Then, Keven can continue checking this issue. Al and/or Askeing, can you help to have the reproducible environment with partners' build on Ikura device? We need to check Wikipedia app. Thanks!
Flags: needinfo?(kkuo)
Flags: needinfo?(fyen)
Flags: needinfo?(atsai)
Whiteboard: [apps watch list1][ikura][POVB] → [apps watch list1][ikura]
I can reproduce this issue on inari.
Flags: needinfo?(fyen)
We've already had three people in QA already test this when I started testing this. I think we've got a solid reproduction here.
Flags: needinfo?(atsai)
This is still present on the ZTE devices as well (OPEN_FFOS_V1.0.0B01_TME)
Why does this depend on bug 859362?  I see it as more of a dupe of that bug.
(In reply to Andrew Overholt [:overholt] from comment #11)
> Why does this depend on bug 859362?  I see it as more of a dupe of that bug.

It might be a dupe, but bug 859362's discussion inferred that's not 100% confirmed. If bug 859362 closes out, then let's retest to see if bug 859362 fixes this.
Actually, I'm just going to dupe it. There's been way too many bugs on this same issue and bug 859362 points to the root cause.
No longer blocks: 859362
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859362
There are also some lower toolbar's issues on Buri and Unagi devices, not only on Ikura(Inari).
I think this issue is not a dupe of Bug 859362.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
### ENV:
Inari
Gaia mozillaorg/v1.0.1 - 09046df332cd217cf4fad55c48ce9ce3f14ee5a4
Gecko mozillaorg/v1.0.1 - d12f4b1d3a9ec82a138693d62c950f7959729a97

1. Click any of the icons on it, there is no response. 


### ENV:
Buri
Gaia mozillaorg/v1.0.1 - 09046df332cd217cf4fad55c48ce9ce3f14ee5a4
Gecko mozillaorg/v1.0.1 - d12f4b1d3a9ec82a138693d62c950f7959729a97

1. The "prev page" & "next page" icons (1st & 2nd icon from the left side) sometimes do not work.
2. Click other icons on it, there is no response. 


### Env:
Unagi
Gaia:     de2a73e76b0bbe05759102d2c370eacb7eece6da
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/765d296cff66
BuildID   20130501070205
Version   18.0

1. No action when click the "Aあ" icon. (3rd icon from the left side)
2. Click "save" icon (4th icon from the left side), and click "Save Page" button, app will save the page and the buttons disappear.
   But sometimes the "Save Page" & "Cancel" buttons still display on screen.
3. Click "bookmark" icon (5th icon from the left side), and click "Saved Pages".
   No action when click "x" icon of bookmark.
(In reply to Askeing Yen[:askeing] from comment #15)
> ### Env:
> Unagi
> Gaia:     de2a73e76b0bbe05759102d2c370eacb7eece6da
> Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/765d296cff66
> BuildID   20130501070205
> Version   18.0
PS. Flash pvt unagi build, then make reset-gaia for install partner apps.

Updated

5 years ago
Whiteboard: [apps watch list1][ikura] → [apps watch list1]
comment 15 has zero relevance to this bug. We could not reproduce the issue on Unagi when I tested. So no, I disagree analysis about to not dupe.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859362

Comment 18

5 years ago
(In reply to Jason Smith [:jsmith] from comment #17)
> comment 15 has zero relevance to this bug. We could not reproduce the issue
> on Unagi when I tested. So no, I disagree analysis about to not dupe.
> 
> *** This bug has been marked as a duplicate of bug 859362 ***

I can see the on all the devices w/ customized UI.
You should use WFM if it's not reproducible on your devices.
I don't think these two are the same issue.

NI to Karen to identify who should be assigned for the tef+ blocker.
Status: RESOLVED → REOPENED
Flags: needinfo?(kward)
Resolution: DUPLICATE → ---
Whiteboard: [apps watch list1] → [apps watch list1],[customization]
(In reply to Al Tsai [:atsai] from comment #18)
> (In reply to Jason Smith [:jsmith] from comment #17)
> > comment 15 has zero relevance to this bug. We could not reproduce the issue
> > on Unagi when I tested. So no, I disagree analysis about to not dupe.
> > 
> > *** This bug has been marked as a duplicate of bug 859362 ***
> 
> I can see the on all the devices w/ customized UI.
> You should use WFM if it's not reproducible on your devices.

No. This was tested and confirmed to fail on Ikura, fail on Unagi above. I doubt you are testing this correctly given the comment you have above has absolutely no relevance to this bug at all.

> I don't think these two are the same issue.
> 
> NI to Karen to identify who should be assigned for the tef+ blocker.

Karen isn't a person who finds assignees for these issues.

Please don't touch this bug again.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(kward)
Resolution: --- → DUPLICATE
Duplicate of bug: 859362
(In reply to Jason Smith [:jsmith] from comment #19)
> (In reply to Al Tsai [:atsai] from comment #18)
> > (In reply to Jason Smith [:jsmith] from comment #17)
> > > comment 15 has zero relevance to this bug. We could not reproduce the issue
> > > on Unagi when I tested. So no, I disagree analysis about to not dupe.
> > > 
> > > *** This bug has been marked as a duplicate of bug 859362 ***
> > 
> > I can see the on all the devices w/ customized UI.
> > You should use WFM if it's not reproducible on your devices.
> 
> No. This was tested and confirmed to fail on Ikura, fail on Unagi above. I
> doubt you are testing this correctly given the comment you have above has
> absolutely no relevance to this bug at all.

Meant to say - Fail on Ikura, passing on Unagi.

> 
> > I don't think these two are the same issue.
> > 
> > NI to Karen to identify who should be assigned for the tef+ blocker.
> 
> Karen isn't a person who finds assignees for these issues.
> 
> Please don't touch this bug again.
> 
> *** This bug has been marked as a duplicate of bug 859362 ***

Comment 21

5 years ago
http://www.youtube.com/watch?v=rxA14U6Bb8g

I cannot see anything related to poor touch sensibility on Ikura.
Or, can you please explain more about the problem?
(In reply to Al Tsai [:atsai] from comment #21)
> http://www.youtube.com/watch?v=rxA14U6Bb8g
> 
> I cannot see anything related to poor touch sensibility on Ikura.
> Or, can you please explain more about the problem?

First, I apologize for some of the miscommunication going on here. Let me backup and explain this. There's two bugs here that are completely separate from each other, but Ikura makes one of them look worse due to the existence of bug 859362.

Bug #1 is that Asymbol button. On unagi, if you hit that button the first time, that language UI shows up like you saw in the video. Now, you close it. Try hitting the Asymbol button again. Notice that the spinner starts spinning - so that means the app picked up the touch event correctly. But also pay attention to the fact that the spinner doesn't stop - which means content failed to load in this case. As you showed in the video, you can reproduce that across *all* devices. I agree on that analysis, but that's a different bug than what's filed here. This bug is talking about all of the icons, not just one of the icons. I'd open a separate bug on this.

Bug #2 is what this bug is talking about. This bug refers to the fact that it's extremely hard to select *any* of the icons on the lower toolbar during usage of the app. Notice that on Buri & Ikura you will be able to reproduce this, but you can't reproduce this on Unagi - 5 out of 6 buttons on unagi will always be responsive, but on Buri & Ikura, responsiveness is a problem on all buttons. Where the point of confusion happened above is that we were seeing bug #1 as well, which made it look like this was not device-dependent any longer. However, bug #1 is a separate bug from this as I explained above. Additionally, pay attention to the level of difficulty you run into using the lower toolbar on Ikura vs. Buri. In my experience, I found Ikura a bit more painful to use in terms of responsiveness of using the toolbar buttons. Buri was a tad better.

My conclusion then is the following:

* File a separate bug for the issue cited in bug #1
* This bug is talking about bug #2. I'll reopen it, but I'm also putting a dependency on bug 859362 instead now given that I think the severity of that bug is causing Ikura to appear worse than Buri. But the general conclusion here is that this bug is happening on the Buri/Ikura devices, not Unagi.
Status: RESOLVED → REOPENED
Depends on: 859362
Resolution: DUPLICATE → ---
Here's another way of saying this using Askeing's testing:


(In reply to Askeing Yen[:askeing] from comment #15)
> ### ENV:
> Inari
> Gaia mozillaorg/v1.0.1 - 09046df332cd217cf4fad55c48ce9ce3f14ee5a4
> Gecko mozillaorg/v1.0.1 - d12f4b1d3a9ec82a138693d62c950f7959729a97
> 
> 1. Click any of the icons on it, there is no response. 
> 
> 
> ### ENV:
> Buri
> Gaia mozillaorg/v1.0.1 - 09046df332cd217cf4fad55c48ce9ce3f14ee5a4
> Gecko mozillaorg/v1.0.1 - d12f4b1d3a9ec82a138693d62c950f7959729a97
> 
> 1. The "prev page" & "next page" icons (1st & 2nd icon from the left side)
> sometimes do not work.
> 2. Click other icons on it, there is no response. 

Look at the items above on Ikura & Buri - the behavior is exactly the same. That's exactly what this bug is talking about.

> 
> 
> ### Env:
> Unagi
> Gaia:     de2a73e76b0bbe05759102d2c370eacb7eece6da
> Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/765d296cff66
> BuildID   20130501070205
> Version   18.0
> 
> 1. No action when click the "Aあ" icon. (3rd icon from the left side)
> 2. Click "save" icon (4th icon from the left side), and click "Save Page"
> button, app will save the page and the buttons disappear.
>    But sometimes the "Save Page" & "Cancel" buttons still display on screen.
> 3. Click "bookmark" icon (5th icon from the left side), and click "Saved
> Pages".
>    No action when click "x" icon of bookmark.

Now look at these items for Unagi. These items are completely different than what's being talked about for Ikura & Buri - they are talking about functionality bustage in the app, but not general lack of touch responsiveness on all buttons available on the toolbar. These items should be filed separately.

Comment 24

5 years ago
Thank you for your kindly explain.

I agree with you that we should separate the bugs.
Are you working on it? Or, I can open another bug for Bug #1 you mentioned.

Also, I'd like to change the title for less misunderstanding.

Remove [customization] for the bug because this one should be a general issue for bad touch sensibility.

Updated

5 years ago
Summary: [Wikipedia] lower toolbar doesn't work → Bad sensibility on Browser and some apps
Whiteboard: [apps watch list1],[customization] → [apps watch list1]

Updated

5 years ago
Blocks: 868335

Updated

5 years ago
No longer blocks: 868335
Whiteboard: [apps watch list1] → [apps watch list]
I'm following up offline on this. Hold up on moving on this bug.
Per talking over email, I'm going to close this bug and open a new bug specifically for bad touch sensitivity in Buri and a different one for Ikura.
No longer blocks: 855322, 855378
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
No longer depends on: 859362
Resolution: --- → INVALID

Updated

5 years ago
blocking-b2g: tef+ → ---
Filed the following issues for followup tracking:

- bug 868758 for the general problem with Buri touch sensitivity
- bug 868759 for the general problem with Ikura touch sensitivity
- bug 868756, bug 868754, bug 868753 for the wikipedia issues Askeing found
You need to log in before you can comment on or make changes to this bug.