Closed Bug 865322 Opened 11 years ago Closed 11 years ago

No error messages on missing credit card info

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: krupa.mozbugs, Assigned: maureenlhanratty)

References

Details

Attachments

(1 file)

Test country: Spain
Tested against: Bango production

steps to reproduce:
1. Start the purchase flow for a paid app
2. In the Bango payment screen choose to pay with a credit card
3. Without entering any info, click Buy (Buy button becomes enabled on clicking inside the credit card field)

expected behavior:
As per mocks, we show useful error messages for each of the missing info-https://www.dropbox.com/s/31h5rx6gl694g0h/Marketplace_Payments_Bango_Flows_040113.pdf

observed behavior:
The form actually gets submitted.
Note that the form  gets submitted and gets stuck in the loading process.
Same as https://bugzilla.mozilla.org/show_bug.cgi?id=865171 - which is fixed. 

There are no error messages on the CC screen since the latest mocks from Maureen, your dropbox link is out of date.
Built as designs...do we need an update?
Assignee: keir → maureenlhanratty
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: