[MMS] Switch mozSms with mozMobileMessage

RESOLVED FIXED

Status

Firefox OS
Gaia::SMS
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: gnarf, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31

Steps to reproduce:

The mozMobileMessage interface will be used in favor of mozSms.  We should switch all the references in the gaia SMS app.
(Reporter)

Updated

5 years ago
Blocks: 845173
blocking leo+ work -> leo+
blocking-b2g: --- → leo?
Comment on attachment 741416 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/9388

r=me except the sms_mock that was added to thread_ui_test.js.

I'll go ahead and remove it and merge this.
Attachment #741416 - Flags: review?(felash) → review+
master: 20e4b6dd1c18eb0a3b3a37f6b2fb6b5bdb6aec51
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
note to triagers: this blocks all other mms work.
blocking-b2g: leo? → leo+
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x  20e4b6dd1c18eb0a3b3a37f6b2fb6b5bdb6aec51
  <RESOLVE MERGE CONFLICTS>
  git commit
conflicts caused by Bug 844900.

I asked approval there.
Just a info: we had a plan to use replace mozMobileMessage.send(...) with mozMobileMessage.sendSMS(...) at bug 85700 but not yet done.
(In reply to Gene Lian [:gene] from comment #8)
> Just a info: we had a plan to use replace mozMobileMessage.send(...) with
> mozMobileMessage.sendSMS(...) at bug 85700 but not yet done.
                                   ^^^^^^^^^ bug 857005, sorry.
Flags: needinfo?(felash)
v1-train: 5991a8a808b99ca26148f20532edfad6a54deaff
status-b2g18: --- → fixed
Flags: needinfo?(felash)
(Assignee)

Updated

4 years ago
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.