Closed Bug 865364 Opened 7 years ago Closed 6 years ago

Intermittent jsdownloads/test/unit/test_DownloadCore.js | test failed (with xpcshell return code: 0), see following log:, | Test timed out

Categories

(Toolkit :: Downloads API, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla26
Tracking Status
firefox24 --- disabled
firefox25 --- disabled
firefox26 --- fixed

People

(Reporter: RyanVM, Assigned: Paolo)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=22162328&tree=Mozilla-Inbound

Rev4 MacOSX Lion 10.7 mozilla-inbound opt test xpcshell on 2013-04-23 15:41:01 PDT for push 789256edc44a
slave: talos-r4-lion-017
Summary: Intermittent jsdownloads/test/unit/test_DownloadCore.js | test failed (with xpcshell return code: 0), see following log: → Intermittent jsdownloads/test/unit/test_DownloadCore.js | test failed (with xpcshell return code: 0), see following log:, | Test timed out
Depends on: 836437
Paolo, any luck with this?
Flags: needinfo?(paolo.mozmail)
(In reply to TBPL Robot from comment #42)
> RyanVM
> https://tbpl.mozilla.org/php/getParsedLog.php?id=26866720&tree=Mozilla-Beta
> Ubuntu VM 12.04 x64 mozilla-beta debug test xpcshell on 2013-08-22 04:11:56
> revision: 229a2402debc
> slave: tst-linux64-ec2-041

This doesn't look good:
04:46:35     INFO -  System JS : ERROR resource://gre/modules/DownloadCore.jsm:664
04:46:35     INFO -                       NS_BASE_STREAM_CLOSED: Component returned failure code: 0x80470002 (NS_BASE_STREAM_CLOSED) [nsIStreamListener.onDataAvailable]
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #44)
> This doesn't look good:
> 04:46:35     INFO -  System JS : ERROR
> resource://gre/modules/DownloadCore.jsm:664
> 04:46:35     INFO -                       NS_BASE_STREAM_CLOSED: Component
> returned failure code: 0x80470002 (NS_BASE_STREAM_CLOSED)
> [nsIStreamListener.onDataAvailable]

That's actually normal and due to a recent change in error reporting across C++
and JavaScript. We have other false positives across the code base. I'm not
sure about what is the plan for solving these, if any exists.
Flags: needinfo?(paolo.mozmail)
I see that the tree is beta, that's probably line 1467 on trunk:

http://mxr.mozilla.org/mozilla-central/source/toolkit/components/jsdownloads/src/DownloadCore.jsm#1467
That last Thunderbird error is caused by a NS_ERROR_PORT_ACCESS_NOT_ALLOWED error, and not the same issue.
The last time this failure occurred was on August 19, which co-incides with a patch to the code relating to this error (in toolkit/components/jsdownloads/test/unit/head.js) I don't see why the change would fix it though, if it is fixed.
Assuming you're referring to bug 852868, did you want to request uplift to Aurora? Too late for Fx24 at this point, but we might able to get it into Fx25 at least.
Going to mark this fixed I think.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #52)
> Test disabled on beta.

And Aurora.

https://hg.mozilla.org/releases/mozilla-aurora/rev/0d71f4d6b63c
You need to log in before you can comment on or make changes to this bug.