Some applications on PaaS cannot be started

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: basta, Assigned: cturra)

Tracking

Details

(Reporter)

Description

5 years ago
See flue.paas.allizom.org

(fireplace)bash-3.2$ s update
Updating application 'flue'...
Application Url: flue.paas.allizom.org
Create services to bind to 'flue' ?  [yN]: 
Uploading Application [flue]:
  Checking for bad links: 9 OK 
  Copying to temp space: 8 OK 
  Checking for available resources: 22393 OK
  Packing application: OK
  Uploading (10K): 100% OK
Push Status: OK
Note that [flue] was not automatically started because it was STOPPED before the update.
You can start it manually using `s start flue`
(fireplace)bash-3.2$ s start flue
stackato.stager: Staging application 'flue'


At this point, the application hangs and never starts.
(Assignee)

Comment 1

5 years ago
have you tried recreating the app?

 $ stackato delete <app_name>
 $ stackato push
Assignee: server-ops-webops → cturra
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 2

5 years ago
It's still getting stuck at "Staging application 'flue'"
(Assignee)

Comment 3

5 years ago
looks like some on the stager processes on the droplet execution agents (DEA) were stuck in a starting state. i have restarted these and everything looks to be functioning correctly once again. can you please give your application a test for me?
(Reporter)

Comment 4

5 years ago
It's still hanging during `s start foo` at the same point as in comment #2.

It also seems like running applications are spontaneously shutting down. Flue, for instance, will work, then start returning the default 404s after a few minutes of running.
(Assignee)

Comment 5

5 years ago
i believe i have tracked down the root cause. there appears to be a firewall setting that is causing a bridge interface (br0) not to come up. i am sorting out how to resolve this and will report back.
(Assignee)

Comment 6

5 years ago
i have sorted out the bridge interface business that was going on and have successfully deployed a test application and seen other push applications. calling this r/fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.