[Dialer] During calling, when making a call using contacts, dialer UI is broken.

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: Anshul)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TD-9655])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 741624 [details]
Dialer UI is broken

1. Title : During calling, when making a call using contacts, dialer UI is broken.
2. Precondition : During calling
3. Tester's Action : Press home key >> Run contacts app >> Select list >> Make a call
4. Detailed Symptom : Dialer UI is broken.
5. Expected : Dialer UI is represented normally
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia revision : 5cbb19e4bb78a7ad879fbe4b9a841e1c35714f5c
8. Gecko revision : 950b402b6188bb2f3ce3176e620ed5249719d720
(Reporter)

Updated

5 years ago
Whiteboard: [TD-9655]
(Reporter)

Comment 1

5 years ago
This bug seems side effect of Bug 832182

When I apply Bug 832182 patch, This bug is shown.

Please check
blocking-b2g: --- → leo?
Flags: needinfo?
Sine bug 832182 went all the way up to v1.0.1 i'm moving this to tef?  

QA: can we get more info here about how to reproduce this?  It's not clear from comment 1 why the patch from bug 832182 would need to be applied given it's already applied.  Can the user still access/use the number pad in the dialer?
blocking-b2g: leo? → tef?
Flags: needinfo?
Keywords: qawanted

Comment 3

5 years ago
Unable to reproduce, the dialer screen works fine. 

See http://youtu.be/b84P919Qo2A

Using a Leo-generated build from 20130425

Gecko 
Gaia   f9d8af05fdd3e1ee4b4d9b715849690333a2dd1c
BuildID 20130425170448
Version 18.0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME

Comment 4

5 years ago
(In reply to Tony Chung [:tchung] from comment #3)
> Unable to reproduce, the dialer screen works fine. 
> 
> See http://youtu.be/b84P919Qo2A
> 
> Using a Leo-generated build from 20130425
> 
> Gecko 
> Gaia   f9d8af05fdd3e1ee4b4d9b715849690333a2dd1c
> BuildID 20130425170448
> Version 18.0

clearing triage flag, since it was nom'd for leo? initially, and my verifcation was against 1.1
blocking-b2g: tef? → ---
(Reporter)

Comment 5

5 years ago
(In reply to Tony Chung [:tchung] from comment #3)
> Unable to reproduce, the dialer screen works fine. 

See
> http://youtu.be/b84P919Qo2A

Using a Leo-generated build from 20130425
> Gecko 
Gaia   f9d8af05fdd3e1ee4b4d9b715849690333a2dd1c
BuildID
> 20130425170448
Version 18.0


I think "http://youtu.be/b84P919Qo2A" is not video of this issue. This issue generate in multi call state.

When calling to A(already connect), device make a call to B(other person)

Then, Dialer UI is represented abnormally(It seems UI that user select both call)
Status: RESOLVED → REOPENED
Flags: needinfo?
Resolution: WORKSFORME → ---
(Assignee)

Comment 6

5 years ago
This issue is being tracked via Qualcomm's case number 01176478 and is fixed in commercial RIL. Please track the case for the status and build details.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Assignee: nobody → anshulj
You need to log in before you can comment on or make changes to this bug.