Closed Bug 865567 Opened 7 years ago Closed 7 years ago

Work - Remove small box with orange border flickering (on top) when swiping in Snapped View

Categories

(Firefox for Metro Graveyard :: Firefox Start, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kjozwiak, Assigned: ally)

References

Details

(Whiteboard: feature=work)

Attachments

(1 file)

When you have Firefox Metro in "Snapped View" and try swiping in the "Navigation App Bar" from the bottom or top of the screen while on either the "about:start" screen or the auto complete screen (when you start typing something in the URL bar), you will notice a small box with an orange border flicker quickly at the top of the screen.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Move Firefox Metro into "Snapped View"
3) Once in "Snapped View", swipe from the bottom or the top while on the "about:start" screen (you should notice a box with an orange border appear)

Easiest way to reproduce the issue is using Windows + Z instead of swiping and you will notice the box appear

Current Behavior:

- Small box with an orange border quickly flickers if you swipe from the top or bottom on the "about:start" screen

Expected Behavior:

- Shouldn't show the tab bar and then quickly hide it when a user swipes or presses Windows + Z
No longer blocks: metrov1defect&change
Priority: -- → P2
Summary: Defect - Small box with orange border flickering (on top) when swiping in Snapped View → Work - Remove small box with orange border flickering (on top) when swiping in Snapped View
Whiteboard: feature=defect c=firefox_app_bar_and_autocomplete u=metro_firefox_user p=0 → feature=work
Assignee: nobody → ally
So this patch addresses the orange block & the ui flicker of the tab strip. However it still bounces (only when it bounces its pure grey).

Now, the ui bouncing to show there is nothing to pull down has some precedent, but Im not sure its what we want.

I would like to do better if possible. I think its trying to transition/animate the swipe in expecting length to be there, except there is nothing to swipe so it transitions back to start & that looks like a bounce.
Comment on attachment 743404 [details] [diff] [review]
no color flicker but bounces

Discussed on irc. Upon reflection, the bounce perhaps ought to be there. If it isn't the user might think that swipe+app bar is broken. With the bounce, the user sees that the browser responded, there's just nothing more to show.
Attachment #743404 - Flags: review?(mbrubeck)
Attachment #743404 - Flags: review?(mbrubeck) → review+
Component: Shell → Firefox Start
https://hg.mozilla.org/mozilla-central/rev/3730657cc0da
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Went through the following "Defect" without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-05-09-03-10-47-mozilla-central/

- Ensured that sliding the "Navigation App Bar" in the awesome screen didn't produce the orange box at the top of the screen (tried on both left and right sides)
- Ensured that sliding the "Navigation App Bar" while typing something in the URL bar didn't produce the orange box at the top of the screen (tried both left and right sides)
- Ensured that sliding the "Navigation App Bar" while on a website in "Snapped View" didn't produce the orange box at the top of the screen (tried on both left and right sides)
- Ensured that pressing the "Windows + Z" shortcut on the above instances also didn't produce the orange box at the top of the screen (tried on both left and right sides)
Status: RESOLVED → VERIFIED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.