[Socorro] Running elasticsearch integration tests with jenkins

RESOLVED FIXED in 57

Status

Socorro Graveyard
Middleware
P3
normal
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: adrian, Assigned: adrian)

Tracking

Details

(Whiteboard: [qa-])

(Assignee)

Description

5 years ago
I recently added functional tests that use elasticsearch into Socorro. They are not run by default at the moment, but I would like jenkins to run them. So I have two questions: 

1. Do we have access to an elasticsearch instance in our jenkins environment?
2. What do we need to do to run those tests? (Set up an ES instance? Change the configuration? )

Thanks,
Adrian
(In reply to Adrian Gaudebert [:adrian] from comment #0)
> I recently added functional tests that use elasticsearch into Socorro. They
> are not run by default at the moment, but I would like jenkins to run them.
> So I have two questions: 
> 
> 1. Do we have access to an elasticsearch instance in our jenkins environment?
> 2. What do we need to do to run those tests? (Set up an ES instance? Change
> the configuration? )
> 
> Thanks,
> Adrian

As of today you can use our new elasticsearch 0.20.x single node install which is dedicated for Jenkins tests.

Use the server name 'jenkins-es20' (an /etc/hosts entry) and port 9200

All you should need to do is point to the server and use a unique index name
Assignee: server-ops-webops → bburton
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Priority: -- → P3
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Blocks: 871963

Comment 2

5 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/ec0839753b5a7fb23c9202f3d231b325102ed6d5
Fixes bug 865599 - Run elasticsearch integration tests on jenkins.

https://github.com/mozilla/socorro/commit/e196ea6f1cd0ddf55f978d28384c49af3dcede05
Merge pull request #1428 from AdrianGaudebert/865599-elasticsearch-jenkins

Fixes bug 865599 - Run elasticsearch integration tests on jenkins.

Updated

5 years ago
Whiteboard: [qa-]
(Assignee)

Updated

5 years ago
Assignee: bburton → adrian
Component: Server Operations: Web Operations → Middleware
Product: mozilla.org → Socorro
QA Contact: nmaul
Target Milestone: --- → 57
(Assignee)

Updated

5 years ago
Duplicate of this bug: 871963
Product: Socorro → Socorro Graveyard
You need to log in before you can comment on or make changes to this bug.