Closed Bug 86561 Opened 21 years ago Closed 21 years ago

big leaks loading nsPresShell.cpp in lxr in two windows

Categories

(Core :: Layout, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 84136

People

(Reporter: dprice, Assigned: dprice)

References

()

Details

Attachments

(3 files)

1 set XPCOM_MEM_LEAK_LOG=filename
2 start mozilla and go to
http://lxr.mozilla.org/seamonkey/source/layout/html/base/src/nsPresShell.cpp
3 when the first page finishes loading, CTRL-N to open a new window
4 in the new window, go to
http://lxr.mozilla.org/seamonkey/source/layout/html/base/src/nsPresShell.cpp again
5 exit
6 check out the log file

If you exit after loading the page once, the total leakage is 6K  Follow all the
steps and the total leakage is 7.3 megs  If you open the new window before the
first page finishes loading, you can cut the total leakage down to 3.7 megs.

according to the leak log, the major offenders are:

HTMLAttribute        734944 Bytes
HTMLAttributesImpl  1872480 Bytes
nsClassList          249688 Bytes
nsGenericElement    1222656 Bytes
nsTextNode          3276720 Bytes
Could this be the generic "New Window" leak described in bug 84136?
it could be.  I'll apply the patch from that bug and see what happens to this one.

Comments on that bug say the existing patch on the bug doesn't fix the leak.
the leak is gone, looks like this is a dup of 84136 

*** This bug has been marked as a duplicate of 84136 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Component: XP Miscellany → Layout: Misc Code
Product: Core → Core Graveyard
Component: Layout: Misc Code → Layout
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.