Show error message when user tries to make a purchase over carrier billing on an unsupported SIM

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: krupa.mozbugs, Assigned: keir)

Tracking

Points:
---
Dependency tree / graph
Bug Flags:
affects-durango +
affects-moss +
affects-seahorse +
affects-seville +
affects-tricycle +

Details

(Reporter)

Description

6 years ago
steps to reproduce:
1. Use a SIM which does not support carrier billing
2. Try to purchase an app from  marketplace stage using carrier billing

expected behavior:
We show an error message when the SIM does not support carrier billing

observed behavior:
Bango tries to make a purchase and fails without any error messages
(Assignee)

Comment 1

6 years ago
So this is when a user uses MT to authenticate and says they are on MOVISTAR. Will investigate further.
(Reporter)

Updated

6 years ago
Duplicate of this bug: 871584

Comment 3

6 years ago
what error code would this be?

Comment 4

6 years ago
The error message is dependent on whether a Bango get a clear error back when trying to make a payment are incorrect network MT auth ..Bango to investigate further
bango still investigating
(Assignee)

Comment 6

6 years ago
So the issue happens when a user incorrect selects MOVISTAR as their network in ESP, and the BV SMS API will send the PIN we generate to them, even tho they are not on the MOVISTAR network.

When the user then tries to complete the purchase it will fail because we will be submitting a non MOVISTAR msisdn to BV, and it will be validated and rejected at this point. 

Are you expecting Bango to offer credit card to these 'non carrier billing' networks?
(In reply to Keir Kettle from comment #6)

> Are you expecting Bango to offer credit card to these 'non carrier billing'
> networks?

Yes
Priority: -- → P3
(Reporter)

Updated

5 years ago
Flags: affects-tricycle+
Flags: affects-seville+
Flags: affects-seahorse+
Flags: affects-moss+
Flags: affects-durango+
Version: 1.2 → 1.3

Comment 8

5 years ago
Please clarify whether you can fail this over to CC payment only after failed MT auth due to the user selecting an unsupported or incorrect mobile network
(Assignee)

Comment 9

5 years ago
So this has been on the table a while, just wanted to clarify a little the actual issue. The original issue was: 

1. A non MOVISTAR user enters a msisdn and selects "MOVISTAR" as their carrier. 
2. They receive a PIN as the BV SMS API doesn't validate the msisdn
3. They try a purchase, which fails and an "payment failed" error is displayed.

It should fairly clear to the user that the payment failed because they are not connected to the carrier which they said they were connected to (the buy page displays the carrier name etc). 

The secondary issue is to allow people connected to other carriers to still be able to make credit card purchases.  This is related to bug 893050. 

Once that bug is fixed we should be able to add a link to the WIFI MT page to say something like 

"Carrier not listed? Click here to pay on credit card"
Depends on: 893050

Updated

5 years ago
Version: 1.3 → 1.4

Updated

5 years ago
Version: 1.4 → 1.5

Comment 10

5 years ago
893050 will help with a fix for this

Comment 11

5 years ago
Assume closed based on 893050 - awaiting test resource/feedback from Mozilla.
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.