Closed Bug 865767 Opened 6 years ago Closed 6 years ago

Zoom in/out cursor not shown (regression)

Categories

(Firefox :: General, defect)

23 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 23
Tracking Status
firefox22 --- unaffected
firefox23 --- verified

People

(Reporter: mozilla, Assigned: waterlo1)

References

Details

(Keywords: regression)

Attachments

(1 file)

Looks like todays Nightly is no longer displaying either zoom-in/zoom-out while viewing an image that's bigger than the current viewport.
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c3a204a6b498
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130423 Firefox/23.0 ID:20130423044135
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e5320348d5d7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130423 Firefox/23.0 ID:20130423052235
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c3a204a6b498&tochange=e5320348d5d7

Regressed by:
2e822e8396c2	Brandon Waterloo — Bug 862117 - Move CSS rule classes relevant to image documents for cursor appearance (zoom in / zoom out) into layout/style/ImageDocument.css. r=roc, r=jaws This stylesheet applies to all ImageDocuments, including those in frames. In old location for CSS rules, some full themes would not show cursors correctly, nor would ImageDocuments in frames. Image rotation CSS rule classes moved to layout/style/TopLevelImageDocument.css.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Blocks: 862117
Keywords: regression
I think I failed to add the reference to the installer for my new CSS file. (That's jaws thought actually). I put it in the makefile but missed the installer.
Yeah, it will need to be added to http://mxr.mozilla.org/mozilla-central/source/browser/installer/package-manifest.in
Assignee: nobody → waterlo1
Status: NEW → ASSIGNED
Hardware: x86 → All
This ought to fix it. I also grepped for any other places where "TopLevelImageDocument.css" is and couldn't find any that we hadn't already covered, so I think this should do it.
Attachment #742297 - Flags: review?(jaws)
Duplicate of this bug: 866236
Attachment #742297 - Flags: review?(jaws) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d6de91faf60a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
I confirm the fix is verified on Windows 7 x64, Mac OS 10.7.5 and Ubuntu 13.04 x86 using FF 23b8.
Build ID: 20130722172257
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.