Application title bar style changes when clicking "show all downloads"

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: glenselle, Unassigned)

Tracking

21 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

62.33 KB, image/png
Details
(Reporter)

Description

5 years ago
Created attachment 741948 [details]
bug.tiff

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

I click on the "Show all downloads" button in the menu bar.


Actual results:

The title bar changed to an ugly Mac OS X title bar (like seen when a popup is shown).


Expected results:

The title bar should not change style it. Instead, it should have its normal gradient style just like the background for the tab area.

Comment 1

5 years ago
Created attachment 743525 [details]
bug.png
Attachment #741948 - Attachment is obsolete: true
Do you still have that problem? Do you have any theme applied?
Try it using Safe Mode 
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

I can't reproduce it on Mac OS 10.8.3
Flags: needinfo?(glenselle)
(Reporter)

Comment 3

5 years ago
(In reply to Tiziana Sellitto [:tiziana] from comment #2)
> Do you still have that problem? Do you have any theme applied?
> Try it using Safe Mode 
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode
> 
> I can't reproduce it on Mac OS 10.8.3

Yes, I just updated to Firefox 21.0 and I am still having the same problem. I did restart in safe mode and the odd behavior went away and the download buttons and menu bar style remained as they should. So I restarted Firefox (not in safe mode) and went through disabling all of my addons. I disabled every one but the menu bar still changes styles when clicking the "download" button.
Flags: needinfo?(glenselle)
Thanks for investigating on this. 
When you start in Safe Mode not only the add on are disabled but theme and hardware acceleration, too.

The problem could be caused by a Theme or Hardware acceleration. So Turn off the hardware acceleration and switch to the default theme as described in 
https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_the-problem-does-not-occur-in-safe-mode
(Reporter)

Comment 5

5 years ago
Ok, I already had it on the default theme but after unchecking the hardware acceleration option in Firefox and restarting the application nothing changed--it is still changing the menu bar styling when I click on the "Show all downloads" button.
(Reporter)

Updated

5 years ago
Version: 20 Branch → 21 Branch
(In reply to glenselle from comment #3)
> I did restart in safe mode and the odd behavior went away and the download
> buttons and menu bar style remained as they should. 

You can try with reset Firefox 
https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems 
or with a new profile 
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

but since the problem doesn't happen in Safe Mode I definitely think it's something not related with Firefox itself, perhaps data, cache...etcetera so I'll check this as invalid.

If you find the origin of your problem don't hesitate to write a comment it could help if anyone has your same problem. 

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

5 years ago
I just reset Firefox and all is back to normal. Thanks Tiziano!

-Glen
You need to log in before you can comment on or make changes to this bug.