inconsistent behavier in bookmark and history tree

VERIFIED DUPLICATE of bug 71768

Status

--
enhancement
VERIFIED DUPLICATE of bug 71768
17 years ago
14 years ago

People

(Reporter: huerlisi, Assigned: matt)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The tree view of bookmark and history in the sidebar are inconsistent in how
they collapse/open.
-In the bookmark page you have to doubleclick the arrow or singleclick the ident.
-In the history page you have to doubleclick the ident or singleclick the arrow.

I prefer the behavier of the history because:
-the arrow is primary to show the state of the folder, collapsed or not. So it
is the right place to change this state. A single click is the right way, 'cause
we can't to anything else with this arrow.
-the ident is primary to show the name of the folder. The default action for a
folder is to open/collapse it. But we can also rename it, or do other nasty
things. So a doubleclick (take default action) is the right method.
(Reporter)

Comment 1

17 years ago
By the way I just reviewed the popup menu for the bookmark page. With the right
mouse button, the bahavier changes to something like the history page:
-folder opens when (single)clicking on the arrow
-folder doesn't open when clicking on the identifier.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 2

17 years ago
fixed? but i wanted to mark this as a duplicate. :(
(Reporter)

Comment 3

17 years ago
I just downloaded a new nightly and... The bahavier seems to be still the same.
I don't know whether you want this behavier, or the "resolved fixed" is wrong.
If this behavier is what you want, I would be interessted in some explenation on
the advances about a consistent behavier

thx simon

Comment 4

17 years ago
reopening. i'm pretty sure the reporter didn't intend to resolve as fixed. i'll 
dupe later, unless someone does so sooner (please).
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Whiteboard: DUPEME
(Reporter)

Comment 5

17 years ago
i would do the work if you can give me some hints where all the things are. if 
you can tell me the source file or some urls to documentation, i'll look at it, 
so that i can tell you wheter i'm able to fix it.
would be my first work on mozilla, besides of some bug reports

simon

Comment 6

17 years ago
*** Bug 89502 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
dup of bug 71768 ?

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 71768 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Comment 9

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.